OSC oddity - working on one computer not on another

I’ve made a simple working osc test , where unreal sends out a value and then reads it back in (just cobbled together from the unreal docs page). this works fine on one computer, but doesn’t work on another computer.
on an osc monitor i can see that unreal is sending the data, and repeating it a bunch of times. when i run the unreal level it is receiving nothing.
the unreal level is the same and the computers are basically the same. the only thing i changed was the ip address. I’ve turned off the windows firewall, and it is using the correct local ip.
what else could be messing up the data and preventing unreal from reading the signal back in?
here is the level blueprint:
and a screenshot of the level running and what unreal is sending out.


Have you tried with a different port? Occasionally ports that I use on one machine (i.e. a Mac) have conflicts on my Windows dev box. I can’t see any obvious reason why they don’t work but something is hogging those somewhere.

Also, it looks like you’re never clearing your OSC message, just adding an Int every tick. So your message is getting larger, and larger, and larger… this can cause some OSC clients to balk at accurately receiving your output. Make sure you clear out your message after each send using a [Clear Osc Message] node.

thanks @robertkhamilton . the clear message made everything look so much nicer. unfortunately changing the port number did not change anything. i did set the osc message variable after every tick which made unreal start to see the osc address, but the value was still 0. i thought this would be handled by the bind and custom event (and it is on the other computer).

Haven’t been spending much time receiving OSC messages in Unreal recently… here’s a post I made a while back with some examples of simple OSC receiving:…xamples-4-23-1

robertkhamilton . thanks for those osc examples. i had been looking at them. they are very helpful esp since there isn’t much online about osc and unreal.
anyway, i addded a get osc message floats and for each loop and started getting values, which works for me. i’m still puzzled why my original setup worked on one computer and not the other, but not enough to spend any more time on it. thanks again.

as an update in case it helps anyone, i had left the app that i use to test osc output open, and it was preventing unreal from reading that port.
only one app listening per port!

:slight_smile: or that