OS X (El Capitan 10.11.6) freezes on actions in Unreal Editor

Dear Unreal Engine Community,

I moved from OS X Yosemite 10.10.5 to OS X El Capitan 10.11.6. I have installed Unreal Engine 4.12.5. On the following actions in Unreal Editor, OS X freezes so that I have to restart computer:

1 creating a new project (log gpulogfile.pdf is attached);

2 moving a Start Player actor (in the project that I created in UE 4.12.5 on OS X Yosemite 10.10.5);

3 going to Landscape Mode (in the project that I created in UE 4.12.5 on OS X Yosemite 10.10.5).

Another problem that I have is when I package my project (created on Yosemite 10.10.5 in UE 4.12.5), packaging finishes successfully, but exe-file has very low-quality graphics, much worse than I see in editor (I attach log-file uelog.pdf and the screenshot executable1.png).

I tried also the version Unreal 4.13.1, but the problems remain there (I created copy of the project transferred from 4.12.5 to 4.13.1).

My graphics card AMD Radeon R9 M380.

Thank you very much in advance for your help.

[link text][1]

[link text][2]

[link text][3]

Well, I succeeded to create a basic project (both blueprint and C++) without freezing OS for Unreal Engine version 4.10.4…

Hi ValentinaU,

Please provide as many of the following as possible:

  1. Your Mac’s specs. You can find this in the Apple menu >About This Mac>More Info> Add the information from this window (serial # not necessary).
  2. The “System Report:” Apple menu >About This Mac > System Report>Hardware (All information listed in the “Hardware Overview.”) You can cut and paste this information or provide screen shots, whichever is more convenient.
  3. If the Crash Reporter window is present when the crash occurs, select “Copy Callstack to the Clipboard,” and paste that information in a document and add to this post. Be sure to hit “Submit” on the Crash Reporter pop-up to send the Crash Report to Epic.
  4. The UE4.log (Located: ~/Library/Logs/Unreal Engine/Editor/)
  5. The ProjectName.log (Located: ~/Library/Logs/Unreal Engine/ProjectNameEditor/)

Thanks,

Steve H.

Hello Steve,

thank you for your answer!

Please, find below the requested information.

1 Mac’s specs

About this MAC:

OS X El Capitan

Version 10.11.6

iMac (Retina 5K, 27-inch, Late 2015)

Processor 3,2 GHz Intel Core i5

Memory 16 GB 1867 MHz DDR3

Graphics AMD Radeon R9 M380 2048 MB

2 System report

Hardware Overview:

Model Name: iMac

Model Identifier: iMac17,1

Processor Name: Intel Core i5

Processor Speed: 3,2 GHz

Number of Processors: 1

Total Number of Cores: 4

L2 Cache (per Core): 256 KB

L3 Cache: 6 MB

Memory: 16 GB

Boot ROM Version: IM171.0105.B08

SMC Version (system): 2.33f10

Hardware UUID: 8DB280BB-1F02-55EA-AA4B-1E75B1A2F9FA

3 Crash reporter windows is not present

4 UE4.log for moving a Start Player actor (in the project that I created in UE 4.12.5 on OS X Yosemite 10.10.5) and UE4 2.log for creating a new blank project in UE 4.12.5

5 ProgProj2.log for moving a Start Player actor (in the project that I created in UE 4.12.5 on OS X Yosemite 10.10.5) and NewProgProj.log for creating a new blank project in UE 4.12.5

Looking at your output log, I found a common error that does not necessarily have one concrete solution:

[ 0]LogInit:Display: LogLinker:Warning: Can’t find file ‘/Game/Architecture/SM_Floor_400x400’

Try right-clicking on your Contents folder in the Content Browser and select, “Fix up redirectors in folder.” Save all. Try packaging.

If this does not fix by itself, then first delete the Intermediate and Saved folders from your Project folder in the Unreal Projects directory. Then open the project, choose “Fix up redirectors in folder” again, and package again.

If the above steps do not work, close the project, Editor, and Launcher. Delete the “DeriedDataCache” folder from the Engine installed directory. Then repeat all of the above steps.

Let me know if this does not resolve your issue.

Hello Steve,

thank you for your answer. I have performed all the steps you proposed but, unfortunately, I’m still experiencing all the above described problems.
I attach the log files for the following situations:

1 After packaging the ProgProj project (graphics is still of low quality in exe-file) ProgProj2.log, UE4.log

2 After moving PlayerStart in ProgProj project which leads to freezing OS ProgProj2_1.log, UE4_1.log

3 After creating new blank blueprint project NewProject2.log and UE4_2.log attached in the following comment

3 After creating new blank blueprint project NewProject2.log, UE4_2.log

I attach also log after packaging: PackagingReport

Thanks for providing the attached logs, however, at this point they are really inconclusive. Please provide the following information:

  1. What version of XCode are you using?
  2. Try packaging a blank, Third Person blueprint project with no starter content and post log
  3. Please back up your “Unreal Projects” folder then completeley remove all versions of UE4 and reinstall UE4.12 only. Let’s stick to the version the project was created in for troubleshooting purposes at this point.)
  4. Provide output log for this version only.

Thanks,

Steve H.

Thank you for your answer.

1 I am using Xcode Version 7.2.1 (7C1002)

2 I have removed all UE versions except UE 4.12.5

3 I have reinstalled Epic Games Launcher and UE 4.12.5

4 Packaging of blank blueprint Third person project went fine: [PackagingReport][1]

5 Graphics in exe file for the third person project is fine except the few first frames:

6 OS is freezing when I try to build this Third Person project

I have not been able to reproduce this on a MacBook Air running El Capitan with much lower specs than your own. I put in a request for more testing for compatibility but in the meantime, have you tried updating the drivers for your GPU?

Are you seeing this low res pixelation in the editor or only in the packaged project?

1 I have upgraded El Capitan to Sierra and OS is not freezing anymore when working in Unreal Editor.

2 However, when running packaged Third Person blueprint project, the first few frames look like this (I do not see it in editor, this problem is only in the packaged project):

After the first few frames everything is fine.

Hello, I do not have the aforementioned problem anymore in MacOS Sierra for the version Unreal Engine 4.13.1.

Thanks for letting us know the updating to Sierra resolved the issue for you.