Ortho projection of walls


i’m trying to do orthoprojection of walls, when I do an ortho projection with textures, after calculating them at max quality, I get horrible result, the best ones are with the coloring output.
When I was using photoscan I could get very high quality orthoprojection of the walls textured, what am I doing wrong ?


Hi antoine.lagarde

Can you please click on the model so that I can see details of the used texturing parameters?
What settings have you used in UNWRAP tool?

Look at the example of what you need to see, so that I can help you…

Screenshot 2016-04-06 18.24.53.png

Thanks here it is

Hi antoine.lagarde

so you have set low resolution for textures. Go to the UNWRAP tool and
change it to these settings - like in the screenshot

Screenshot 2016-04-06 18.40.00.png

when it is done, use the TEXTURE button to generate the texture with proper settings

Ok should I change the gutter value aswell? I unwraped and I’m getting 69% utilization with 48% quality

Hi Antoine.lagarde

Change the MAXIMAL TEXTURES COUNT to get higher TEXEL%, in the ideal case it is 100 %.
The TEXTURE UTILIZATION is secondary information, that will never be 100 %.

Okay all good it’s working now, is there a way I can improve the resolution on those orthoprojection, or I should build the model in many small parts and get each of them the max res texture for that purpose

Hi antoine.lagarde

I am not sure what are you referring to but in the ORTHO tool you can set proper settings for the ORTHO projection resolution…

Ok I tried a small comparison, I generated the same orthophoto with photoscan and RC, in RC I cannot get a better output than the one I have here, even if I increase texture resolution over the estimated one, the result is the same. (this is a crop in the orthophoto btw)

How is RC doing its ortho projection, in PS for example, you don’t need to build the texture or vertex colors to get it, you just go all the way to the mesh, then build and ortho projection with your desired lvl of quality and it reprojects the pictures based on the mesh and camera orientation.
In RC you have to generate the textures so if your model is big I guess it’s spread all around it and you get bad results :frowning:

Hi antoine.lagarde

Can you please make a screenshot of the RECONSTRUCTION = SETTINGS = COLORING/TEXTURING sub-menu where I can see what sort of settings are you using ?

here it is

Hi Antoine

And in UNWRAP are you using FIXED DETAIL or MAXIMAL TEXTURE COUNT setting ?

I’m using maximal texture count

Hi antoine.lagarde

Can you send me the dataset for review to milos.lukac@capturingreality.com ? So that I can take a look at what can be the issue…

dataset sent by pm

Hi antoine.lagarde

Thanks. I will download and take a look at it in the morning, when I come back from Prague.

Hi, could you look into it ?


Hi antoine.lagarde

Have it just run on High reconstruction. will check it when come back home and inspect the results…

Hi antoine lagarde

You need to change one more setting for texturing part. in RECONSTRUCTION ribbon -> SETTINGS -> COLORING/TEXTURING change DOWNSCALE IMAGES BEFORE TEXTURING from 2 to 1
1 = NO downscale is applied and use full resolution images for texture projection.

It was already at 1 when I run the last calculation :frowning: