Orbit camera too fast

Hello guys,

So when I tried to rotate my camera view in the view port (ALT+LMB), the orbit speed is super fast. Even I set Camera Speed to 1, it still rotates very fast. The zoom in/out is in normal speed, just rotate is not working. I had opened Editor Preferences-- Level Editor–Viewports, and checked “Use distance-scaled camera speed” and “Orbit camera around selection”, restarted engine, still doesn’t work.

Did I miss anything? Looking forward to hear your response, thank you very much