Option to disable Font antialiasing


It would be really nice if there was an option right in the editor to disable the font smoothing / antialiasing. The only solution I was able to find required to modify code, but I think something as basic as this should be present in the editor’s options.


You can disable antialiasing by double clicking your font asset in the Content Browser.

Then on the right side of the new window, change from “Runtime” to “Offline” under Font > Font Cache Type. This basically means that the font will no longer initialize at runtime and “pre-Render” the font sheet at the time you update it in the editor.

When set to Offline, click “Yes” then select the font from the font selector with the font size you want. Once its imported, you have a bunch of options including the ability to uncheck Antialiasing. If you don’t see it, untwirl the “Import Options” section. Once you make a change, it won’t magically take effect. Go back to the Content Browser, right click the Font and click “Reimport”.

Be careful with changing other settings. It could mess up how the font is displayed. If you mess something up, change the Font Cache Type back to Runtime to reset.