option for "cache location"

i discovered the option cache to system (activate by default) and cache to project folder, and it saved me because im low on disk space on system hard drive (ssd 120 go)

But, it seems that part of it stay on disk system, because it still going to full the disk, clearly not as fast as before, but from run to run i had more 15go who disappear when i cleared cache.

Hi Aure
go to C:\Users\USER\AppData\Local\Temp\
and clear everything what’s inside

Best to set it to D:/RC_temp/ and clear it from time to time…

yeah i found my way, i check disk space from time to time and when near the limit i save all on rc, start new one, workfow>application settings there i change cache back to system, clear all, then i put it back (with rc restart when asked).

strangely by going to the temp folder directly, i have no admin right to clear (really wierd because others folders of temp arent in that state) soo is it my pc being dumb?? XD XD or ICC mmmh… XD XD

Hello Wishgranter

I come back to you because i’m running in similar problem: i bought the promo to continue my tests, i have a project of 980 images, went through alignment smoothly, now reconstruction step. In high detail, Cr failed after long time calculation, with error out of disk space. True C: drive is short, 80go free. But program is installed on D: , and i put cache location to project folder on D: aswell. D: drive have 1,5to free. Problem is that rc keep going to save some temp files on C:
Any idea?

Hi Aure
let’s see, I need to test it. Have you seen some files being saved or you just observe the C: drive is filling up or ?

Hi

Well i didnt see files saving, but c: is clearly filling up. Tried to see but… a bit difficult inside temp folder…

I retried a reconstruction, in normal detail this time, so far it looks ok, but i’m really interested by high detail XD.

If you have set it to D: per project folder, then the C: should not be used by RC.
but I’m already checking whether there‘s some issue, just to be sure…

Good morning Wishgranter

Normal detail was successfull, but still problem is there. For normal detail it seems rc took up to 8go on C: drive, but i cant find any temp folder related to RC, or i’m not looking right place.

At the beginning i thought it was because i forgot to save, so no project folder and RC caching to C: . But i checked, its something else.

I’m having the exact same problem.

Any way to avoid using the C: drive will be most appreciated. For now, i’m just stuck having to wait 5 days before switching to a machine with a larger SSD.

No matter what I choose, the program will not change the memory cache from the system default.

When I choose “custom”, no further option is provided for me to change the memory cache location to a new directory.
When I choose project folder, no change to memory location occurs it still goes to system default.
So, I am forced to constantly clear the system default cache.

Is this a bug?
Or is this a limitation of the license type?
I am on a Promo license.

Hi agreen
Everything is there, please take a look at the screenshot below

CACHE_Location.png

  1. Set the cache location to CUSTOM
  2. Then click in the second line and set the location

Then confirm and exit RC so that the changes are accepted and used

Hi agreen.

This is not a bug, just it work not as desired.

When you just create new project and place images inside it and want run alignment. RC have not choice rather than save temporary data to system temp dir.

If you want use “Project folders” you must save project right after import images (and background feature calculation must be off).

I found when i tried project folder, it went to my system temp too.

I guess because of this “If you want use “Project folders” you must save project right after import images (and background feature calculation must be off)”

I went back custom and it has been fine.