OpenSSL Error when starting UE4Editor


i hope this is the right topic.

So i had the problem when starting the epic games launcher that nothing happened after it updated it. But i needed unreal engine 4

So i build it from source code with this manual: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums

I then tried starting UE4Editor.exe but it crashed without error or showing up.
After some research i found out it crashed in “UE4Editor-XMPP.dll” at the function “sha1_block_data_order”.

So i thried to fix the error and managed to get it to work.

I just did this:

  • I opened “\Engine\Source\ThirdParty\OpenSSL\OpenSSL.Build.cs” and replaced all ocurrencies of “OpenSSL102Path” with “OpenSSL102hPath” where “Target.Platform == UnrealTargetPlatform.Win64”
  • After trying to compile UE4 it returned an error. I just needed to rename “libeay32.lib” to “libeay.lib” and “ssleay32.lib” to “ssleay.lib”

After that i can start UE4Editor. Maybe te same problem is in the Epic Games launcher. I hope this helps someone.

My Computers specs:

Operating System: Windows 10 Pro 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
Language: German (Regional Setting: German)
BIOS: BIOS Date: 04/12/17 16:31:25 Ver: 05.0000C (type: BIOS)
Processor: Intel(R) Celeron(R) CPU J3455 @ 1.50GHz (4 CPUs), ~1.5GHz
Memory: 16384MB RAM
Available OS Memory: 15780MB RAM
Page File: 9424MB used, 14902MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.17134.0001 64bit Unicode


Until the OpenSSL fix makes it into the launcher, you can create an environment variable called “OPENSSL_ia32cap” with the value “:~0x20000000d”. (Both without the quote marks)


Thanks, I had been looking for a solution for a while, and the only one I found was compiling the source code.
Now the Epic Games Launcher works.