OpenLevel node and open command freezes in a packaged build

Hi all!

When using the open console command in a packaged build, the window doesn’t respond, the app freezes.
After about 30 seconds, the windows starts responding again, but the application is completely black.

I tried using the OpenLevel node instead, and there’s the exact same problem!!

It also works perfectly within the editor, completely smooth then.

Some details

  • I tried adding my two levels to the “list of maps to include in a packaged build” but without success.
  • My levels are literally just a floor and a cube in the cube, so it’s not loading time.
  • The same thing happens with open followed by an ip address.
  • This is a VR game without any VR plugin (“Start in VR” checkbox) but I have an Oculus Rift S.
  • My umap is in the “Levels” folder in Editor, so I tried using the path “Levels/MyLevelName” in both the command and the node but without success

make a copy of your config folder and save it in some other place(backup) then delete all files in config folder except one that has input in its name. then make sure open command works while in editor. package.test!

Thanks for suggesting this way of debugging, that’s good to know! :slight_smile:
Unfortunately it didn’t change anything, it works in Editor, but both the command and the node still produce a black screen in a build.

Turns out it is something VR related!!

If I disable Oculus VR and SteamVR plugins, it all works just fine! But whenever they’re enabled, even in a package of one of the UE4 template projects, it does that black screen! But I want to make a VR game so that’s a bit worrying…

If anyone knows what I’m doing wrong for it not to work when in VR? Thanks…