Opening windows project on Mac give XCode problem

I have a project with C++ code that I want to test on my iphone. Therefor I have to open the project on my mac, but I’m having problems because unreal doesn’t seem to ‘find’ XCode when I open that project.
There is no compile button, and in the editor preferences under Source Code, the dropdown for ‘Source Code Editor’ is empty. Also when I double click on a C++ class, nothing happens. I did generate the XCode workspace and I can open it in XCode, but from the unreal editor, when I click ‘open XCode’ nothing happens either.

I’ve also tried to make a new C++ project on my mac, and then everything works fine, so the problem is only showing up in the project I generated and worked on in windows with visual studio.

Does anyone have any idea on how to fix this problem? How can I have UE editor recognise XCode for that project?

Apparently there is a pluging that you need to enable under programming called ‘XCode Integration’, which is not enabled by default if you create the project in windows.