Opening packaged project on Mac - Assertion failed: HasFoundDataDirectory

Hey guys,

Our packaged project works fine on Windows, however when package from a Mac for Mac the packaged executable doesn’t work. This is the only thing we found, how to fix this ? :

Last login: Wed Jul 22 12:00:45 on ttys000
lees-iMac:~ lee$ /Users/lee/Desktop/Tobacco\ RD\ Mac/MacNoEditor/ ; exit;
Assertion failed: HasFoundDataDirectory [File:/Users/build/BuildFarm/build_++depot+UE4-Releases+4.8/Engine/Source/Runtime/Core/Private/Internationalization/ICUInternationalization.cpp] [Line: 117]
ICU data directory was not discovered:

[Process completed

Ok, so we’ve tried on different Macs, same problem. What is even more important is that we tried packaging an Epic’s demo and still we have the same issue so it’s nothing relatated to our project.

Would really appreciate some help here.

Hi Robbie,

I was on vacation and I didn’t see your post in the other thread asking me to look at this until now, sorry.

It looks like either the packaging failed to copy some files or for some reason the code that sets the current working directory on startup failed. Could you try moving the to your desktop and launch from there so there are no space characters in the full path to the app? I’m pretty sure we should be handling this correctly, but that’s the only slightly unusual thing I see in the log you sent.

Hi Michael,
I tried what you suggested and copied the app to the desktop, but I keep getting the same result. The file seems to package without any errors but when I try to run the app nothing happens. Also when I show the contents of the application the binaries folder is empty.
I appreciate any help you can provide.

Thank you,