Download

Opening any blueprint crashes editor

Hello,

Whenever I try to open up a blueprint actor the editor crashes. I have read that it is most likely either my controller, character, gamemode, game instance, game state blueprints, but even deleting all of these still causes the crash.

I also realise that it must be a reference all of the blueprints have to something that got corrupted, but I’ve tried deleting almost everything I have in my project one and by one and the issue is still there.

The problem is I could go back to a version from a few days ago, a backup, but I’ve done an insane amoutn of things over the weekend and having to do all of that again would be a nightmare.

Is there any way at all to somehow pinpoint the blueprint that is causing the crashes? Like with some sort of minidump or crashlog or something, I have no idea where to look for this. If someone can tell me where or how I can find the corrupt blueprint that would be amazing.

I’m out of ideas, hope someone can help. :frowning:

You probably have memory leak in some blueprint, it usually happens when blueprint gets corrupted.

So, first make backup of whole project. Zip whole project and move that file to another folder on same drive.

Now get something like TotalCommander, or use windows explorer. You need to find which blueprint file is corrupted. If you click one of them blueprint editor loads them all, because of dependency. And if one is corrupted it crashes editor.

How do you find offending flie:
Delete half of blueprint files, open editor and see if clicking on one of the mcrashes whole thing. If it does not, then it was one of deleted files. Restore half of them. Check again, repeat until you find corrupted file.

But sometimes crashing happens because you made some really strange material, or did some weird thing with pointers (References).

There are also error logs for editor, maybe something in logs can give you some clues.

Ps. MAKE backups, some version control system, or good old zip and backups every time you make major changes.

Ok, thanks! I’ve already deleted a whole lot with no result. I’m just going to keep trying that and hope I find the corrupt blueprint. If not I’ll be back here in a few hours. :stuck_out_tongue:

What I don’t understand though is that even when I try to open a camera shake which normally has not a single reference to anything of my own blueprints it causes a crash. So I don’t know, but could that mean that the problem is caused by something greater than my own blueprints?

Update: Ok I’ve removed ALL blueprints in my project and the crash still happens.

I’ve created a completely new blueprint based on actor and opening that newly created actor also crashes the editor instantly.

Also materials are not affected, I can still open all my materials just fine. It’s only blueprints, everything else still seems to work.

In my experience there are quite a few things that can cause this. I spent about two days locating a single collapsed graph which caused crashes moving from 4.12 to 4.14 (I think). The crash was caused even by loading a BP which simply referenced the offending BP in a variable.

Also - I had a similar problem where I’d been experimenting with a plugin which had it’s own variable class, and when I disabled the plugin it caused problems because I still had the variables in the BP.

I don’t use any plugins. And the crashing also appears on a freshly created blueprint that has no code or variables or references in it yet, just a blank blueprint. Creating it works. But when I try to open it it crashes the editor. I’ve removed pretty much everything I can from my project and the crashes still happen.

I also tried installing an update for the editor version I use which was 4.17.1 and now it’s 4.17.2, but still not fixed.

What else could be causing this?

I Have the same thing. At first The Engine Did not launched. I thought level corrupted. But figured out it is all blueprints.
4.22.3
Don’t know exactly, perhaps after moving files to another folder happened…
Still trying to figure out

I have this problem when i try to trigger a game mode blueprint function from my character blueprint, i don’t now why it happens.

Epic fixed a lot of those early crashes.
Make backups either in version control or manually by zipping whole project and storing on ANOTHER hdd.

When corrupted blueprint happens usually editor crashes when you try to see that blueprint.
And if you mean that editor crashes when you try to call that function. Yo u probably can open that blueprint, so first backup whole project then open it and delete that function.

Corrupted stuff happens when you open 2 copies of editor, and one locks one file while other copy tries to save, then you force it to close.
Or when you delete actor and force remove it.

You also can try to fix redirectors on whole projject and subfolders.

If you try to open the editor end it’s crashing, try find what file is crashing using the LOG than you cut the file out of the project to be able to open the editor again.

It’s always good to use a repository.