OpenGL 4 Issues in Windows

Ive been testing the opengl renderer in windows 7 but getting serious issues, Can people look at the video and tell me if they get the same issues. Im on AMD HD 5850 1GB.

To create a shortcut to run the editor in opengl mode just create a copy if the UE4Editor-Cmd.exe ,right click and select properties, then under the shortcut tab edit the target line to follows:

Win64\UE4Editor-Cmd.exe -opengl4

Double click the shortcut once finished and the editor with boot with opengl enabled.

Video of Issues:

PS, also get a very weird issue of the screen being upside down and inverted when recording with Fraps, had to rotate the image 180 degrees for ingame footage.

UD4 is very powerful and demands allot from your computer, your graphics card isn’t one of the best to be used, especially running Fraps to record. I’m using a Macbook Pro 15 with Intel I7 & 16GBS RAM and GeForce GT750m 2GBS and I pace myself. UD4’s dropping resolution to maintain performance. I have only one solution, upgrade your graphics card or cpu.
Cheers :slight_smile:
Specs required from the site:
Desktop PC or Mac
Windows 7 64-bit or Mac OS X 10.9.2 or later
Quad-core Intel or AMD processor, 2.5 GHz or faster
NVIDIA GeForce 470 GTX or AMD Radeon 6870 HD series card or higher

Also bear in mind that OpenGL 4 is at early stage of implementation. Though I guess all testing and bug reporting for OpenGL 4 will help!

That’s not the case Bud, When i run in DX11 mode i don’t get any of these issues and the engine runs fine. This only happens in OpenGL 3/4 rendering modes. Feedback from others running opengl in windows is needed.

On GTX 780 I don’t see any difference in Blueprint Office on OpenGL4 compared to DX11 at first glance.

Though I probably should take closer look.

As far as I can tell lightmap shadows have strange issues with compression and are lower quality.

It’s a two part problem.

  1. What are the state of the OpenGL Drivers on your PC for your hardware
  2. What are the limitations of UE4 on the OpenGL version you are running.

My understanding is that our OpenGL 4 support is on-par with our DX11 support (it’s what folks are running on the Mac), however the state of drives (and work-arounds for drive problems) will cause mixed results using this API on various platforms.

Sorry double post.

Hi Paul, Im running the very latest AMD Beta 14.3 drivers i think downloaded today. Im running in the video opengl 4, but have the same issues with opengl 3 mode. Ive also tried with the last official release AMD drivers and get the same problems. For example loading the Reflections example the entire editor just locks up but is not windows unresponsive, just sits their with geometry on screen but the the shader compiler stage doesn’t move, In opengl 3 mode the map opens and compilers shaders but the same graphic issues in the video ive posted so i would say it’s not just Opengl 4 related. Ive also compiled my own version of the engine to see if any difference and exactly the same outcome, In dx11 mode everything runs fine.