Open Project failed in UE4Editor

Gentoo, nvidia-drivers-346.35, clang-3.5.1, I have managed to compile everything as described in

emerge =mono-3.2.8
git clone
cd UnrealEngine
make SlateViewer
make ShaderCompileWorker UnrealLightmass UnrealPak UE4Editor
make UE4Editor-Linux-Debug 
cd Engine/Binaries/Linux && LD_LIBRARY_PATH=. ./UE4Editor
cd Engine/Binaries/Linux && LD_LIBRARY_PATH=. ./UE4Editor-Linux-Debug

UE4Editor opens but exits (shutdowns) when project is created or project is opened.
Even ./UE4Editor-Linux-Debug -onethread cannot help.

It says in console:

or with strace

I have run ./UE4Editor-Linux-Debug under gdb, it stops at the beginning:

(gdb) r /root/Unreal\ Projects/MyPuzzle01/MyPuzzle01.uproject
Starting program: /var/tmp/COMPILE/UnrealEngine/Engine/Binaries/Linux/UE4Editor-Linux-Debug /root/Unreal\ Projects/MyPuzzle01/MyPuzzle01.uproject
warning: Could not load shared library symbols for
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/".
Using binned.
Increasing per-process limit of core file size to infinity.
[New Thread 0x7ffff7e7d700 (LWP 7183)]
[New Thread 0x7ffff7e5c700 (LWP 7184)]
[New Thread 0x7ffff7e3b700 (LWP 7185)]

Program received signal SIGTRAP, Trace/breakpoint trap.
0x00007ffff7bce8ed in raise (sig=5) at ../sysdeps/unix/sysv/linux/pt-raise.c:36
36	../sysdeps/unix/sysv/linux/pt-raise.c: No such file or directory.
(gdb) bt
#0  0x00007ffff7bce8ed in raise (sig=5)
    at ../sysdeps/unix/sysv/linux/pt-raise.c:36
#1  0x00007ffff6e9fb27 in DebugBreak ()
    at /var/tmp/COMPILE/UnrealEngine/Engine/Source/Runtime/Core/Public/Linux/LinuxPlatformMisc.h:32
#2  RangeCheck (this=0x7ffffffe4220, Index=0)
    at /var/tmp/COMPILE/UnrealEngine/Engine/Source/Runtime/Core/Public/Containers/Array.h:679
#3  operator[] (this=0x7ffffffe4220, Index=0)
    at /var/tmp/COMPILE/UnrealEngine/Engine/Source/Runtime/Core/Public/Containers/Array.h:736
#4  operator[] (this=0x7ffffffe4220, Index=0)
    at /var/tmp/COMPILE/UnrealEngine/Engine/Source/Runtime/Core/Public/Containers/UnrealString.h:215
#5  FLinuxFileMapper::MapCaseInsensitiveFile (
    this=0x7ffff78e7f48 <GCaseInsensMapper>, PossiblyWrongFilename=..., 
    at /var/tmp/COMPILE/UnrealEngine/Engine/Source/Runtime/Core/Private/Linux/LinuxPlatformFile.cpp:472
#6  0x00007ffff6e567bc in FLinuxPlatformFile::DirectoryExists (
    this=0x7ffff78e8370 <IPlatformFile::GetPlatformPhysical()::Singleton>, 
    Directory=0x7ffffffe4360 L"../../../../../../..")
    at /var/tmp/COMPILE/UnrealEngine/Engine/Source/Runtime/Core/Private/Linux/LinuxPlatformFile.cpp:843
#7  0x00007ffff6c70d65 in IPlatformFile::CreateDirectoryTree (
    this=0x7ffff78e8370 <IPlatformFile::GetPlatformPhysical()::Singleton>, 
    Directory=0xdf1800 L"../../../../../../../root/Unreal Projects/Mypuzzle02d/I


Could you please post your entire log from the terminal, start to end, and include any stack trace (if available).


Here are logs for ./UE4Editor-Linux-Debug -onethread and normal run:

Have you tried building the default Development build and running without -onethread though?

There don’t seem to be any obvious errors, aside from the JSON ones which are benign and so I wonder why you are running Debug with -onethread.

It might be possible that you’ve hit some threading bug with this combination (Gentoo, Debug build, -onethread) but I’ll ping @RCL about this as well.

Run it under gdb, and pass the complete path to .uproject as the first argument.

gdb UE4Editor-Linux-Debug
r /my/project/project.uproject

and see if it traps to the debugger. You can also set breakpoint at FLinuxPlatformMisc::RequestExit to see what causes it to exit.

I have added gdb output to my question!

Could you please do “bt” after you trap and add the resulting callstack?

P.S. I strongly recommend NOT to run the engine as root.

I have added the “bt” output. I have run it as a user with the exactly same result.

Move your project into /var/tmp or move the engine under /root. There is a bug that makes the engine crash if project and the engine don’t share any other directory except /.

It works! Thanks!