Open Level with Options Blueprint

How do I open a new level with GameMode change fromm Blueprint level?

What am I doing wrong here? LOG:

Options = Game=class’GoblinGame_C’

[2014.09.11-21.14.32:675][728]LogUObjectGlobals:Warning: Failed to find object ‘Class None.GoblinGame_C’
[2014.09.11-21.14.32:675][728]LogWorld:Warning: Failed to load game mode ‘class’GoblinGame_C’’ specified by URL options.
[2014.09.11-21.14.32:676][728]LogWorld: Game class is ‘GoblinVSGolem_C’

Options = Game=/Game/Blueprints/GoblinGame_C

[2014.09.11-21.18.38:494][543]LogUObjectGlobals:Warning: Failed to find object ‘Class None./Game/Blueprints/GoblinGame_C’
[2014.09.11-21.18.38:494][543]LogWorld:Warning: Failed to load game mode ‘/Game/Blueprints/GoblinGame_C’ specified by URL options.
[2014.09.11-21.18.38:494][543]LogWorld: Game class is ‘GoblinVSGolem_C’

Options = Game=GoblinGame_C

[2014.09.11-21.20.23:156][996]LogUObjectGlobals:Warning: Failed to find object ‘Class None.GoblinGame_C’
[2014.09.11-21.20.23:156][996]LogWorld:Warning: Failed to load game mode ‘GoblinGame_C’ specified by URL options.
[2014.09.11-21.20.23:156][996]LogWorld: Game class is ‘GoblinVSGolem_C’

Options = Game=GoblinGame

[2014.09.11-21.22.00:158][101]LogUObjectGlobals:Warning: Failed to find object ‘Class None.GoblinGame’
[2014.09.11-21.22.00:158][101]LogWorld:Warning: Failed to load game mode ‘GoblinGame’ specified by URL options.
[2014.09.11-21.22.00:158][101]LogWorld: Game class is ‘GoblinVSGolem_C’

Options = Game=GameMode.GoblinGame

[2014.09.11-21.23.17:227][217]LogUObjectGlobals:Warning: Failed to find object ‘Class None.GoblinGame’
[2014.09.11-21.23.17:227][217]LogWorld:Warning: Failed to load game mode ‘GameMode.GoblinGame’ specified by URL options.
[2014.09.11-21.23.17:227][217]LogWorld: Game class is ‘GoblinVSGolem_C’

The level loads right but doesn’t change the game mode. Question is, how to use this options thingy? What am I missing in the ‘Class ---->None<----.GoblinGame’ part?

Thanks,
Z.

Same problem here. My project’s name is MagThrustContentOnly, and when I copy my game mode’s reference, it contains CoasterGameMode.CoasterGameMode. I’ve tried using CoasterGameMode, CoasterGameMode.CoasterGameMode, MagThrustContentOnly.CoasterGameMode, and MagThrustContentOnly.CoasterGameMode.CoasterGameMode. They all still result in the “Failed to find object ‘Class None.CoasterGameMode’” error, with or without " -game" appended.

How exactly are people getting by without a simple (or working, at least) way to open a level with a specific game mode?

Yea, exactly.
Have you tried with 4.5?

Unfortunately, my subscription very recently expired and I won’t be able to resubscribe immediately. So, I’m still at 4.4 for now.

Same problem here - has anyone figured this out?

Hi all,

The string you want to put in Options in this case is the path from /Game. So in this case, assuming you have the GoblinGame BP in a Blueprints folder, you would enter ?Game=/Game/Blueprints/GoblinGame.GoblinGame_C

I have entered a feature request to make the Options input for this node to be a little easier to use (UE-5003), and I will let you know if it gets implemented in any way.

Hope that helps!

1 Like

Thanks Ben - That worked!!!

You have no idea how much time I spent trying to guess the format of that string :wink:

a couple of years later… nada :slight_smile:

I got this successfully working in 4.23 if anyone from the future needs to do this, purely blueprint project. The trick for me was adding the . and the GM name again. The file path browses to the game mode in your content browser but you’ll need to add the . and your GM name again_C. For instance my GM was SteamVRSUB_GM and it was located in the VRExpansion/Vive/ folder so my path was “?game=/Game/VRExpansion/Vive/SteamVRSUB_GM.SteamVRSUB_GM_C”