Open level when game is packaged doesn't work

Hi all, i have a simple menu where first button is for travel to a map. During editor all works fine, but when i package project and execute it through .exe file, when i click button nothing happen.

Hey Fanto88,

I’ve assigned a member of support staff to look into this, and they’ll post here if they have any questions for you. Thanks for report!

Hello Fanto88,

I was unable to reproduce this issue on our end. I have a few questions that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. If you go into your blueprints and use File > Refresh all nodes feature before packaging, does this help?
  2. If you put level name in manually does this issue still occur?
  3. Can you reproduce this issue in a clean project?
  4. If so, could you provide a detailed list of step to reproduce this issue on our end?
  1. This don’t help, problem is still present
  2. If i put name manually nothing change
  3. I reproduced issue in a clean project
  4. I can’t do a detailed list of steps… but could i send new project, maybe?

Hello Fanto88,

If you would like to down a project and attach it in reply I will be more than happy to take a look for you.

This is .7zp project


Any news?


It works now?

Hello Fanto88,

I do not have access to this file. Could you change permissions so that I can download project?

Hello Fanto88,

After testing this issue in project provided I did not have any issues changing levels in a packaged project. If you use map “Test” within your project, level changes as expected. Could you try using this map for your test and let me know results?

Thank you for your time. I have to apologize with you because i think that problem was caused by windows 10, because with new upgrade i can access to other levels and now all works fine. Thank you for your help.

Hello Fanto88,

I am happy to hear that your issue has been resolved. I will be marking your last comment as answer. If this issue returns please feel free to reopen this thread with additional information.

Make it a great day

Were you able to identify this Windows 10 problem? I have exactly same troubles now, UE4.14.3, Open Level blueprint function works perfectly with VR Preview mode, but stops when run packaged project. I don’t see any errors into log during packaging.

i did not include map in ‘list of maps to include in a packaged build’. once i included map under project setting / packing, everything worked as expected.

original comment:
i am experiencing same issue. open level works when playing in editor, but not after packaging into .exe. log error is “failed to resole [level name]”.