"Open Level" only works in Editor - Not in Standalone or packaged game

Hi Community!
i try to create my own game and it works fine, but then i wanna test the packaging because last time I had a problem there.
The packaging works also fine but i cant load a level in the “standalone” / packaged version …

The Main menu etc is working well but everytime i wanna try the multiplayer or singleplayer with a OPEN LEVEL Node (yes, the map name is correct) it doesnt work and redirect me to my main menu…

  • in editor window its working
  • i packaged the game (Windows 64bit – build configuration: development) dont work…
  • i tested it with “Cook Content for Windows” dont work…

I searched in my logfile for errors for my Map “Karte_Alpha” which is not loading… but i dont really found something -> i attached the log file with all Map infos and Warnings.

Where is the problem? Is it a blueprint error?

I hope you guys can help me…


I just packaged some levels (for windows 64), and did not have any issues with the open level bp’s in 4.19 , but i had some other issues that worked in editor and not in packaged. Once i deleted all save games in my project folder first and all previous project packaged save games in app data/ local. then packaged, things worked ok.

Go in project setting==maps and modes==or packaging dont remember and add all of your maps to the list.


Didnt think of that, that would be in packaging, path to map needs to be correct as well.

I Have the same problem…

In Editor works 100%, i see maybe need build map, i try it but not work for me.

Any solution?

Navigate to Project Settings -> Packaging -> “List of Map s you want to include in Package” and add your Maps from the Game Folder.[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_179837_1577200042044_678”,“title”:“191207capture.png”}[/ATTACH]


after 5 years and i still have this problem plz tell me if you or anyone found a solution… i tried the (list of maps) but it stills the same


I have got the same. I fix the problem, In Unreal Engine 4.18 go to Project Settings, then go to Asset Managuer, and there are a list named “Specific Assets”, add all your maps, and other stuff you want to be in yor game. I did that and launch the game for windows, and all maps work fine.
Hope this help, if you did not solve your problems already.

luck with your project.


Thanks HAMLET PC!! it worked for me

I had a similar issue on 4.26. My maps wouldn’t be cooked during the packaging process. However I only had this bug when starting my game with the “Launch On” button within the editor.
HAMLET PC’s solution worked for me (thanks a bunch!)

Alternatively, you can set “Cook on the fly” to True in the Cooker settings. It also fixes the issue but it seems to be less “optimized” and takes more resources.


@Elou44 I’ve tried the cook on the fly option but it never ends compiling, since it needs a virtual machine (like you I try to launch on the phone via the “Launch” button)
Having set all my maps in the project asset manager doesn’t work, same for including maps in the package settings.
No matter what I do, “Open level” never opens anything. I’ll have to put the apk on the store in order to try since apparently the behavior is different, but I really would like to launch on the phone (I don’t have internet on the phone, so each time uploading to the store and waiting for somebody to try is far away from ideal).
Maybe there is an other way to try on the phone without download from store or via “launch”, but I haven’t found yet.

@bigheart3dstudio I tried that, also “cook everything”, in fact I have explored all solutions I found on the net!

But I just found the culprit :laughing:. I was building for shipping since at the same time I send versions on the google play store, and it was the issue.
If I use development build (with “for distribution” unchecked) it works, my maps are correctly opened on the phone.
A big relief for me, I can go on and track bugs with prints without waiting for somebody to download from the store, check bugs, check log etc. I’m gonna save a huge time!

Edit: I just realize I’m responding to a very old message, sorry…
Edit 2 : The build mode must be “development” (haven’t tried debug or test) but also maps must be included

1 Like

you so much (Cook on the fly) option fixed my problem now I can sleep xD

follow this, it works

Go to project settings
in the packaging section
find the advance and expand it
there you will find
List of Maps to Include in package build
there just add all your maps…

Didn’t work for me. I did everything in this thread and more, and still have no idea why my maps won’t load. I’m actually quite impressed that I’m having this issue with Unreal. I’m on 5.1, but I’ve tried other versions without luck.
I’ve even added the build data from my maps, but still, it just reloads the same map when I walk into the collider, or if I try to change map via console. This is absurd.

I had this same issue just now. This is very strange but creating a dummy Level (with only a distant cube in it) which I loaded before the actual level I wanted to load and then loading actual level works for some reason. It kept failing to load the first level in standalone mode. I am using streaming levels.

So I’ve found a solution. For some reason, calling the level within a blueprint directly doesn’t work. Instead, I had to create a function in the game instance and call that in my blueprint. Between the level unloading and loading the next one, the blueprint code got lost and so it just reloaded the same level. Using the game instance fixed it.