Open Level Crashing in UMG

I have a simple menu setup. When I try to call open level after a button click (like in the Stream) the engine crashes with the following message:

[2014.08.12-16.18.57:488][790]LogWorld: Game class is 'PLGTestGameMode'
[2014.08.12-16.18.57:489][790]LogAIModule: Creating AISystem for world MainMenu
[2014.08.12-16.18.57:490][790]LogWorld: Bringing World /Game/Maps/UEDPIE_0_mainmenu.MainMenu up for play (max tick rate 0) at 2014.08.12-18.18.57
[2014.08.12-16.18.57:491][790]LogWorld: Bringing up level for play took: 0.000884
[2014.08.12-16.18.57:494][790]PIE: Info Play in editor start time for /Game/Maps/UEDPIE_0_mainmenu -0.79
The thread 0x2ce0 has exited with code 0 (0x0).
The thread 0x1888 has exited with code 0 (0x0).
The thread 0x3004 has exited with code 0 (0x0).
The thread 0xfdc has exited with code 0 (0x0).
[2014.08.12-16.19.00:716][151]LogPackageName: SearchForPackageOnDisk took   0.076s to resolve test.umap
[2014.08.12-16.19.00:716][151]LogBlueprintUserMessages: asdfasdf
[2014.08.12-16.19.00:791][151]LogPackageName: SearchForPackageOnDisk took   0.074s to resolve test.umap
[2014.08.12-16.19.00:792][151]LogNet: Browse: /Game/Maps/test
[2014.08.12-16.19.00:792][151]LogLoad: LoadMap: /Game/Maps/test
[2014.08.12-16.19.00:804][151]Cmd: MEM
[2014.08.12-16.19.00:814][151]LogMemory: Platform Memory Stats for Windows
[2014.08.12-16.19.00:815][151]LogMemory: Process Physical Memory: 512.64 MB used, 544.10 MB peak
[2014.08.12-16.19.00:815][151]LogMemory: Process Virtual Memory: 424.83 MB used, 457.67 MB peak
[2014.08.12-16.19.00:815][151]LogMemory: Physical Memory: 6702.35 MB used, 16322.46 MB total
[2014.08.12-16.19.00:815][151]LogMemory: Virtual Memory: 1030.09 MB used, 134217728.00 MB total
[2014.08.12-16.19.00:816][151]Allocator Stats for TBB: (not implemented)
[2014.08.12-16.19.00:816][151]LogLoad: World /Game/Maps/UEDPIE_0_mainmenu.MainMenu not cleaned up by garbage collection! 
[2014.08.12-16.19.00:816][151]LogReferenceChain: Searching referencers for MainMenu. This may take several minutes.
[2014.08.12-16.19.00:865][151]LogReferenceChain: Generating reference graph ...
[2014.08.12-16.19.00:867][151]LogReferenceChain: Level 0 has 8 nodes ...
[2014.08.12-16.19.00:871][151]LogReferenceChain: Level 1 added 28 nodes ...
[2014.08.12-16.19.00:874][151]LogReferenceChain: Level 2 added 58 nodes ...
[2014.08.12-16.19.00:878][151]LogReferenceChain: Level 3 added 52 nodes ...
[2014.08.12-16.19.00:881][151]LogReferenceChain: Level 4 added 60 nodes ...
[2014.08.12-16.19.00:885][151]LogReferenceChain: Level 5 added 79 nodes ...
[2014.08.12-16.19.00:888][151]LogReferenceChain: Level 6 added 6 nodes ...
[2014.08.12-16.19.00:891][151]LogReferenceChain: Level 7 added 0 nodes ...
[2014.08.12-16.19.00:892][151]LogReferenceChain: Generating reference chains ...
[2014.08.12-16.19.00:892][151]LogReferenceChain: External Referencers:
[2014.08.12-16.19.01:115][151]LogReferenceChain: (root) GCObjectReferencer /Engine/Transient.GCObjectReferencer_0->
[2014.08.12-16.19.01:115][151]LogReferenceChain:   MainMenu_C /Game/Maps/UEDPIE_0_mainmenu.MainMenu:PersistentLevel.PLGTestPlayerController_1.MainMenu_C_0->Property
[2014.08.12-16.19.01:115][151]LogReferenceChain:     (PendingKill) PLGTestPlayerController /Game/Maps/UEDPIE_0_mainmenu.MainMenu:PersistentLevel.PLGTestPlayerController_1->Property
[2014.08.12-16.19.01:115][151]LogReferenceChain:       Level /Game/Maps/UEDPIE_0_mainmenu.MainMenu:PersistentLevel->OwningWorld
[2014.08.12-16.19.01:115][151]LogReferenceChain:         (target) World /Game/Maps/UEDPIE_0_mainmenu.MainMenu
[2014.08.12-16.19.01:168][151]LogLoad:    (Object is not currently rooted)

D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.4\Engine\Source\Editor\UnrealEd\Private\Editor.cpp(6675): Fatal error:
World /Game/Maps/UEDPIE_0_mainmenu.MainMenu not cleaned up by garbage collection!
   (Object is not currently rooted)


might be well wrong on this, but i’ve learned never to use the same name twice, might be an idea to use other names for your actual maps, eg MainLevelMap which contents the MainMenu blueprint/umg

Ok will try that

nope still the same error

sorry i can’t help then, it was just a guess on my side, maybe if you post a few pictures on how you have set up your menu it might help others to trouble shoot

Ok I had to remove the menu first now it works like a charm.

Yeah it’s a bug in UMG / PIE.