Only using 2 cores where machine have 24 core

Hi,

there is a issues which i am facing with swarm agent. it not using all cores for baking. after 95 % it only using 2 cores where machine have 24 core. so baking is really fast till 95. after it became ■■■■ slow… if anybody have some fixes for this issue it will be really great full.

thanks
jose

enable the developer options( by setting the developer options to true) & setting local jobs default processor countto the number of processors to use

enable the developer options( by setting the developer options to true) & setting local jobs default processor countto the number of processors to use

Cause there is a baking job with at least one big lightmap (2k or 4k). When you have many small to medium tasks on baking maps, all of them are calculated on free processors/cores. When one of them ends its task, begins the next. When one processor/core begins a task with a big map, this map is only calculated on one processor, by now it can’t be divided, so this task may take a long time to terminate on only one core. Frecuently when the distributed tasks begins, one of the cores receives the biggest maps to calculate (4096) and if you are using production quality and have tweaked the Lightmass settings towards highest quality results, all of this will multiply exponentially baking times so one big cooking task may take more time than all the other tasks distributed on all of the other cores. Usually the reason of using 4K/2K lighmaps is to raise up quality baking of big meshes. So all begins with good modeling and unwrapping habits as avoiding too big meshes in editor and good polygon distributing on uv space.