Download

Only some input keys are working on a new character class BP?

I created a new character so that we could switch between 1p/3p modes without having to switch characters.’

It handles character movement and input fine looking/moving but any input like E, leftmousebutton etc. events including action input events setup in the settings are not firing at all. I tried enable input on BeginPlay and also tried creating a playercontroller class and also tried enable input on that.

But certain keys like say, f10 fire fine.

This has me at a standstill. Any ideas? Input isnt disabled, no extra characters in the level, just a playerstart. Tried settings auto receive input player 0, made sure use mouse for touch was unchecked.

Get this… if I make a new input action in settings that has a previous unused name (like testingInput) and then plug it into the execution chain… it works fine, so I tried re-creating the basic “fire” for LMB and “interact” for E.

Neither worked, nor do their raw counterparts.

Don’t know if this is it, but I had similar frustrations and found the input was being blocked. I turned off Consume Input in the details panel and my inputs worked.
eaa076e2e794c3e5a46e286095e42aa9faf82ce7.jpeg

Thats the stock settings I figured it was fine and it makes sense to leave it on. Will try thank you.

Unfortunatly that did not help.

In this example everything works except the raw E input and the InputAction Fire (thats the stock one, which I tried deleting LMB and re-adding it to be sure) LeftMouseButton raw doesnt work either.

GameMode

Character Class Settings All Stock basically

Move your “E” event to your Controller Blueprint and it will start working.

Add a custom event to your Character Blueprint … Add the “E” event to your Controller … On “E” event get your character and then call your custom event on the character. This changed for me from 4.7 to 4.8 … if I remember correctly.

Very odd. Up until yesterday when I went to move some old logic from the prototype character to this alpha everything was working hunkey dorey thats when I went wtf and tried remaking logic, replacing keys with different keys, making a PC etc. I tried putting InputAction (I use them whenever possible because theyre easier to find, and can be set in config files) and raw inputs in a custom player controller and then set my gamemode to use that. No cigar, again no input is being executed from a player controller nor a character except weird keys like F10, not f9, tild (~) obviously. And yet mousex and mousey as well as WASD for input axis for characterMovement are are working fine as day.

Will try using a input event to call a custom event from my character but thats a pretty radical way to change your development. No input was even giving print strings so… we’ll seee.

As far as I understand … your controller is responsible for the input interaction between the user and the player … so it actually makes sense to be in there. I had my stuff in Character Blueprint as well … upgraded to 4.7 from 4.6 and had to move it to the Controller Blueprint.

There is probably a setting for changing the default behavior or a reason why it works like that … but I am cool with the way it works.

p.s. it was the upgrade from 4.6 to 4.7 when I first noticed this, not 4.7 to 4.8.

Sure enough… no result. No inputaction events or raw input mouse or keyboard but keys like F10 do work calling the custom event from the cast.

No errors.

Thats a very odd result I’ve been prototyping with blueprints since 4.6.1 and been making pawns/characters without player controllers (except the stock one), except a few times for vehicles and such.

Edit: Heres where some debugging goes somewhere, everything here except the stock inputAction(Fire) work in both PC and Char classes. I assume because these are some of the few keys not bound to an inputAction

Time to delete intermediate folders and re-setup allllllllllllllllllllllllllllll those input actions… sigh I love unreal sometimes…

Edit2: Remade some inputAction events by deleting them all (with a backup saved of .ini of course) and remaking them. No cigar. Time for a re-build!

Im still at odds with this. I deleted the intermediate folder. I deleted all my inputaction and axis setups and remade them. If I remake the standard “fire” event with a key not used before. It works fine. If I set it to something used before like E or LMB it doesnt work.

Everything works hunkey dorey in other maps in the project. What coudl be eating up my input?

Edit: I deleted every intermediate file I could thing of. Made a fresh map and a fresh character and game mode and now it seems to be fine. Go figure.

Anyone that has this problem. It was a blueprint that worked fine at the time but for some reason was causing all these errrors. Backto normal.