Download

Only one blendshape animation gets imported into Unreal {Missing blendshape animations}

Okay, so I have trouble getting my Maya animations (created out of blendshapes) to work in Unreal. I have three blendshape animations in total which I have baked in Maya and exported out as FBX. After importing them into Unreal the blendshapes were there, but not the animations.
Thinking that maybe a rig was needed even though that isn’t usually the case with blendshapes, I created one joint and bound my whole mesh to it. (Deleting NonDeformer History first)
Then I keyed some animations, baked them (Bake Simulation) and after checking that they had been baked okay, I selected my mesh and root joint and exported them out via FBX (settings attached). The only warning I get pertains complex animation which I assume can be ignored.

When importing the FBX file into Unreal I check “Import Animations”, “Import Morph Targets” and set the Animation Length to “Set Range” since Exported Time gives me a weird bug with much more keyframes than are actually there. After the import, only one of the three blendshape animations is working even though all three blendshapes can be selected and deform the mesh.
I’ve been troubleshooting this now for days on end (changing settings in Maya / in Unreal; bake simulation before export; baking during export; changing blendhshape controls to attributes) and getting one blendshape animation to work instead of none is the best I could achieve. I’m really at a loss now and if someone could look over the file and point me in the right direction I would greatly appreciate it.

FBX file: http://we.tl/XAQp6E7rH7
Maya file: http://we.tl/ld5hOq3erf

What version of ue4 are you using? I had issues with 4.10 not importing fbx animations correctly on occasions. Bug was reported and is now (hopefully) being worked on.
If youre using 4.10, try going down to 4.9 as that worked fine for my skeletal animations. I have tried any blendShape stuff tho, but Im working on a facial rig now so Ill have a look at that today.

Edit:
Just taking a look at your file: complex animation comes from the animCurve on your primary meshes visibility channel.

Ok found your issue: You are applying each target as a separate blendShape node. Thats wrong… Only one blendShape node should be on your head mesh that contains all targets. You have to select all targets at the same time and add them to a single node.

Edit2:
One thing tho… your eyebrow and eyelash meshes dont follow the blendShapes of the head, youll have to create separate targets for each of those and animate them in sync…

Thanks!

So that means I just shouldn’t key my visibility channel? [Edit: I know I shouldn’t key my visibility channel in the first place. I forgot to lock my visibility before keying] (Or delete the animcurve afterwards?) When pressing ‘s’, all your channels are keyed, though, right?
I’m also using Unreal 4.9, btw.

Thank you so much! I imported the animation into Max today and had the same result as in Unreal so I figured it must be smth in Maya - never would’ve guessed it’s the order I’m selecting my blendshapes, though.

Regarding Edit2: This means I have to create lashes + eyebrow blendshapes for every face blendshape, right? – I found a very good method by mcvijay to have the eyebrows follow the faces of the head: Attaching Eyebrows to Face | Animation and Creativity
I’m not sure if this would work in Unreal, though, since constraints don’t work.

I forgot to add, the complex animation thingy has many reasons, for one, it doesnt support direct connections from something other than animCurve nodes. So your control objects arent supposed to be in the .fbx export.

As for the eyebrow/eyelash thing, yeah you can do that. Only need to make sure you bake those bones to animation before exporting your clips then.