Only half a sequence playing/not working in general?

Hi, I’m making a simple main menu UI, and I wanted to make the camera pan around the scene once you press a button to open up another menu. I’ve got a sequencer set up, with sequences for going to each menu and back on a button click.

However, for some reason, the first sequence works fine, but if you trigger any more, they don’t play properly. For example, when I go to the settings menu (forward and right of the player), then back to the main menu (behind the player’s left shoulder), the camera ends up in front of the player, too low down, and at the wrong angle. The weirdest part is the fact that when I preview the sequences, they look completely fine, so my transform values aren’t off or anything.

It almost feels like half of the sequence is playing, or it starts playing and condenses it all down so that it doesn’t move as much. If you keep going back and forth, the camera moves less and less too, so it’s like whatever is going wrong keeps escalating too.

There’s also this weird ball that appears sometimes when I run the game, not sure if it’s related but I would also like it gone. I can’t click on it in editor while the game is running in a separate window either, so I have no idea what it is:

Can anybody help? Thanks in advance

No idea about your sequencer problem.

But that ball is the default pawn that you possess when you are “flying” in the editor.

This happens because when you press play, this ball spawns and gets possessed wherever your camera is located before you pressed play. If you have a sequence that plays on BeginPlay, the ball still spawns but instead of it, the camera in your sequence is possessed and the ball is left there.
To get rid of it, place a Player Start below the map where it spawns out of view.

I seem to encounter the same problem, my tutorial has multiple stages, for the transition from stage 1 to stage 2, it works fine, but when moving from stage 2 to stage 3, it moves only half the distance.