Online Multiplayer (Doesn't work over steam, Works over LAN)

I have been trying to network a multiplayer game for the past few weeks, and have been unsuccessful. When running on my machine, or via LAN I connect just fine. I have the online subsystem, and subsystem steam working, but I have never made a connection. It has been hard troubleshooting these problems, since I don’t have regular access to two networks. Any help would be appreciated, thanks!

The tutorials my project is based around:

Hello - i’m definitely having the same exact errors as you - this worked in a 4.13 LAUNCHER build with the AdvancedSessions plugin used … but I am having no such luck with 4.14.3 SOURCE BUILD even with just using the engines FindSessions default node (NO PLUGIN REQUIRED).

MAKING SURE that your DefaultEngine.ini has the following (below) as well steam obviously running… I cannot get sessions to be viewable across the WAN… i’m setting up to check local LAN now - but i imagine the same will be true…

AGAIN - This works in 4.13 with the same exact setup no problem.




; Uncomment the following line to use the Null Subsystem
; Uncomment the following lines to use the Steam Subsystem


My DefaultEngine.ini has been properly modified, and even went so far to make sure the ThirdParty Binaries were in place. I upped the max results for sessions in case that was an issue too. The part that really has me stuck is that I receive ‘No servers found’ instantly, as if the search failed, however, it did not. Might this be an issue working on steam’s AppId=480 “SpaceWars”?

The project seems to run fine in simulated multiplayer, replication etc seems to be okay. It is the pier-to-pier connection that isn’t being made. Here is the example project I’m trying to get working.

Props to UnrealTek!

In your DefaultEngine.ini add this for verbose online logging:


In addition to that, you can set breakpoints in the online subsystem if you run it as “Debug Game Editor” and -game (under Project Properties → Debugging → Command Arguments in Visual Studio).

Although I’m a big fan of blueprints, I’ve often found it necessary to drop into the C++ to debug online issues.

Have you solved your problem? I’m having the same problem