Download

One on One instructions: Importing a Mesh from 3dsmax without Lightmap problems

Hello,
i get a crysis now!!!

How can i import from 3ds Max a Static Mesh without problems with the Lightmap? I can import things but after Rebuild the lightmaps all objects looking black.
I never had such problem in Unity…
Many Thanks in Advance
halobungie

Add a UVUnwrap modifier to the mesh. Set it to channel 2. Unwrap your object so that it doesn’t have any overlapping polygons in the UV space. Save and export that file. Unreal does have a UV unwrapper that you can use to do this, but its a bit **** :slight_smile:

Alternatively, go into your mesh in unreal engine, then look for the option to generate UV coordinates, this basically does an automated unwrap (much like how Unity does it, but you have to choose to do it in Unreal, whereas its automatically done in Unity).

If you make custom uvs for your lightmap, make sure that they are spaced adequately. If not, you will run into issues with shadow bleeding.

Hello,
what have i to do exactly in the Unwrap Modifier? Can you show a picture from your Unwrap Modifier, please?
Please help me, the Meshes are all Black.
Kind regards,
halobungie

Take a look at THIS, and THIS, also THIS and, if you want, all of THIS ( UDK LIGHTMAPPING section).
Hope it will be helpfull.
:slight_smile:

There are plenty of videos on youtube explaining how to UV Unwrap things in 3DSMax. Its a pretty big area of 3d artwork after all. Main thing is you need to make sure that no polygons are overlapping and they stay within the 0…1 space but maybe its better if you don’t know how to do that to use the automatic unwrapper in Unreal. Click on the mesh in the content browser, go to “window->generate UV’s” and it should open a new tabbed window in the mesh window. Select “create new” option and make sure UV channel to save results to: is set to UV Channel 1 and click apply.

This automatically unwraps the mesh as you would have done it in 3dsmax (it doesn’t work well for complex meshes though). But should at least stop you having errors.

And there is no EASYER WAY to do this?

Thats an easy way ^^

Simple create a second uvmap.

In my opinion this UE4 FBX importer is a GREAT ****, sorry…

This has nothing to do with the FBX Importer, thats a simple problem with your models.
I came from Unity to and i got no problems, because my models have good UVMaps allready. I only have to vreate a second Channel and it works.

Hello,
over four days now of testing and importing and trying but without success, that’s my problem i know.
Can i send to one guy here in this Forum my mesh, please. And this person can have a look, how i can do it, PLEASE.
I love the UE4 Engine - She is mush better like Unity but in Unity i have never had problems with Importing and Lightning.
But now i will work With UE4 - but i have to find a solution for this problem.
I hope someone can help me.
Kind regards,
halobungie

Is it trolling or what?
What the problem? You can create UV for 1st channel, but can’t for 2nd channel?

Here is a great tutorial from fighter5347.

http://www.youtube.com/watch?v=z5yc-bKbHyc

if this one not helps you out i would start with uvmap tutorials. I dont know wich programm you use for modeling, but there are a lot of tuts for every program

Hello Zeorb,
can i send you my model, perhaps the problem is in the mesh i don’t know.

O.k. i will give a Instruction what i do:

  1. I import a FBX-Mesh that i have take in Unity too without some problems.
  2. I do nothing else only Rebuild the Lithtning and then the mesh looks bad dark and with a bad Shadows too (that can not work i Know because there are no Second UV channel.
  3. I go to the Static Mesh Editor and create for the “UV Channel 1” an Unique UVs with Apply.
  4. Save that an go back - Build the Lightning new - a get the Message “Lightmap UV overlapping by 96.8%. Please adjust content - Enable Error Coloring to viualize”. The mesh looks bad and the Shadows too.

What’s wrong?

First of all you should learn how to uvw unwrap a object, you will need this not only for your lighting maps….
When you learned how to unwrap a object, the rest is simple….

  1. Take a look on UVW Unwrapping tutorials on youtube!
  2. The rest is easy “adding a second UV channel”

If you need a sample, export a object from UE4 and open it in MAX

Hello, I am fairly new with Unreal Engine stuff. This with black mesh, bothers me. However, I have seen if you do not have to LightmassImportanceVolume from the beginning of the project and build a lightmap after it is mostly black, including content that comes with the example. If I then include LightmassImportanceVolume in the same project causes no change. I still have black meshes. Ok if I get the lightmap error on my own content, but unreal components should be worked. Is anyone else having similar problems or is it all in my head.

/ / M
ps
excuse my bad English Google.

ok but what about organic models? i saw many tutorials about this but all examples are from hard surface modeling and geometric stuff. how the hell im going to pay atention to the change of direction in organic models? its imposible. all poligon faces points to every direction.

Ok, go back to that mesh, look down the list of details and look for the one that says UV channel (or something similar), it will be set to 0, you need to set it to 1. Its a quirk of how the generator works that it doesn’t set the lightmap channel to 1 after it creates the channel 1, so you have to do it manually.

As I mentioned before though, the automatic UV algorithm isn’t very good so your lighting will likely still look kind of poor (but it at least won’t give you these errors). Best option is to do the UV Unwrap yourself, as I said there are plenty of tutorials on youtube about how to do that.

This is the reason why i stick with fully dynamic lighting. Since UE4 is deferred, it can handle many dynamic lights without performance issue. At the moment we can also fake Dynamic GI using Skylight/Ambient Cubemap in PostProcessVolumes. So i suggest to use dynamic lights. Just my 2 cents. :slight_smile:

Can someone explain this for me at least. Why is the mesh dark in the editor but normal if you look through the camera. What have I missed?
fc5d4d4d20be3ca4291f74726798004d522a9911.jpeg