One eye flickers black in Oculus

Hello,

In one section of my level, the right eye in my Oculus will flicker with black sections. While this is happening, I also get bad tearing or streaking when moving my head. When I run this level in the editor in VR preview mode, it runs perfectly smoothly at 75fps with no flicker.

Another problem (which may be unrelated) is that some objects in the level move with my head a bit. It’s hard to explain, but they sort of shift around based on my head movements instead of staying put.

Windows 7
NVIDIA GeForce GTX 980

I just recently updated the NVIDIA Gameworks driver to 358.78 and Oculus runtime to 0.8.

Hello jessekirbs,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you check to make sure that the drivers for your graphics card are up to date?

Hello jessekirbs,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Hi Rudy,

I seem to have the same problem. The right eye flickers black. I am using a Windows 7, Quadro K4200 and Intel Xeon with Unreal Engine 4.10.2.

I only have this problem when I make it as a native package. And all my drivers are up to date.

Edit

The problem also occurs when you preview the game. But in this both eyes gets flickered.

The same problem is also present in Unreal Engine 4.10.2

So the native packing problem has been resolved but it still has lag (it might flicker I guess, because I have a bit lagging videos), I updated my Quadro drivers to 358.91. But the when I preview in the editor I still have the problem.

Can you reproduce this issue in a clean project? If so, could you provide a detailed list of steps to reproduce this issue on our end?

I have the same issue. Windows 7 with latest nVidia drivers. Seems to be related to 2D, screen-space UI Widgets. I switched them to World-space UI widgets and all the flickering goes away. The flickering and artifacts are not visible in the preview window, but they are visible in the headset.

Yes it was a clean project I tested it on.

Steps:

Build a sample project without starter content

Preview it in Oculus

What should happen:

Clean and non lagging game flow

What actually happens:

Lagging and flickering video game. annoying.

How did you do that?

Well this won’t really solve the problem if you don’t want 3D, in-world widgets. But you can look at the properties for your widget and under the “UI” heading change the Space to World instead of Screen. I’m interested if that also fixes it for you.

I didn’t create a widget though I tried removing FirstPerson HUD because it was projecting a 2D texture but still the same problem.

I have also tried removing the FirstPerson HUD, still the same problem.

Hello akshay,

Could you try updating your graphics drivers to the latest version to see if this helps with the flickering?

Hi Rudy,

All my drivers are up to date. I don’t want to compare but Oculus rift is working fine in Unity 5.

Have you tried setting it up from your side?

I had an idea after reading over you last post. It turns out the reason I could not reproduce this issue is because I was trying it is standalone. After running the test in VR preview, I was able to reproduce this issue on our end. I have written up a report (UE-25832) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Workaround: Try using Stand alone Alt+ Enter

Make it a great day

I don’t know if this helps, but if I do a full light build (even Preview), the flickering goes away. Move a light to make the map need a light rebuild, and the flickering returns.

UE4 4.9.2