OnComponentHit Event no detecting Actor Has Tag

Here is the blueprint

I just want that the component: HeadKill detect the actors that has the tag: BalaGranada. But it doens´t detect none of them:

I set the tags inside the actors class defaults. Any clues? Thanks!!

in your blueprint, add the the tag to your root component and see if it’s detected there. tags can exist in a couple different locations and so needed to be searched for in different ways. so for example, if this is a character. select the character root, and in the details panel, scroll all the way to the bottom, and place the tag name there in the ‘actor’ category.

since you’re using component hit, if you placed your tag in the component, then use the ‘hit component’ pin and drag out the ‘component has tag’ function check.

Hi Paradoc

Still not working, but thank you very much!

just realized I confused something. so that second part wouldn’t have worked. can you post a screenshot of where you put the tag entry in the BalaGranada actor?

in your 'OnComponentHit(HeadKill), pull out the pin ‘OtherComp’ and select ‘ComponentHasTag’ and use that instead.


I put everywhere in the actor that I want, in class default and in every component. It is a projectile actor that has the tag name: BalaGranada



Yes, I did it, but didn´t work too =/

ok, have you verified that the two actors register hits with each other? for example, oncomponenthit, just print the display name of the otherComp

I put the print string and nothing happens.

I imagined that, the “Actor Has Tag” is having no effect on the oncomponenthit event. I can´t “find” the actors with that tag. But it is strange, because the actors do have the tag inside them…

both are set to block, I also tried the event: oncomponentbeginoverlap and nothing happens too.

It is something wrong about the tags.

I will find it, hehe

Seems to be a bug, indeed:

if there is no collision detected, it won’t be able to get to that next step. what type of collision does your projectile have? i’ll take a few minutes to look at the project if you want to share it.

Hi everyone,

This is a known issue as FilipeTessaro has pointed out and is in our system as UE-22797. I am going to mark this as answered for tracking purposes.