OnComponentBeginOverlap works in simulation, doesn't work in VR Preview

I need to make something for somebody, but I don’t have a , so I tried using simulate to check if the collision/overlap was being detected and it was, but when the other person tried it out in VR Preview it didn’t detect anything.

It didn’t matter what collision channels I used.

On both BP_MotionController and buttonTest I have this:
Simulation generates hit events is enabled.
Generate overlap events is enabled.

On BP_MotionController I have this, it doesn’t matter what the collision is on:

On buttonTest I have this, it is a static mesh and I have tried pretty much all collision channels:

This is the project:


In front of the spawn is a white cube which should be triggered when you hit it with a hand.

Make sure that your friend or partner also have the same channels and settings. I am often making things without the before I plug it in and then just plug in the for test runs.

He is using the exact same file as I linked in the question.

Hello MrGoatsy,

I tested the ability to overlap with the motion controllers in a clean project. I was unable to reproduce this issue on our end. I also tried downloading the project provided, however I could not get the project to work correctly. Could you try and reproduce this issue in a clean project?

The project I attached is a clean project based on the VR template.

I think it is a problem with printing text, it sometimes prints but other times doesn’t, if I set the material to change on overlap begin/end it does work.

If you check your output log do you see your print string there for when you were overlapping the object in the level?

I can’t test it because I don’t have a VR device, I will post later when the person who has the VR device has tested it.

Hello MrGoatsy,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.


Was this ever solved? I am having the same issue…