Once in BP debug mode on OSX, you cannot bring up right-click menu on nodes

Hi Guys,

On the preview build of 4.8 (P4). Once you are running your game in the editor, you cannot go to the BP editor and right click on nodes to bring up a menu. This prevents the ability add break point on nodes or remove them.

Tommy.

Hi Tommy,

Does this happen in a new project as well as your current project? I just tested this in 4.8p4 on a MacBook Air and I was able to right-click on a node during PIE without any issues. I tried both with the BP Editor docked in the main bar as well as free floating, and I tried both with the trackpad and with a USB mouse. Is there anything else about your setup that I might be missing?

I cannot reproduce this now! Thanks Ben.

Found it… You need to have hit a break point in your BP network. Then this occurs.

Okay, so I tested this in a new Third Person template project in the ThirdPersonCharacter BP, using Event Begin Play > Delay (.02) > Print String. I added a breakpoint on the Print String. On PIE, the breakpoint brings be to the Print String node, and I can right-click on any node and in the graph to make adjustments to breakpoints, as normal. Is there a more in depth test I can try? Are you able to reproduce this in a new project as well?

Hi Ben,

Sorry this is so hard to reproduce on your end. I’ll check again and get a set of iron clad sets to repro.

Tommy.

Wow! I cannot reproduce this again. 100% sure I had this nailed. I’ll keep an eye out.

Tommy.

Okay then, I’ll go ahead and resolve the post for now, but if you do get some more repro steps please let us know!