On Screen Debug messages not printing

So I know that 100% my blueprints are hitting my print string node, however nothing is actually printing to screen when I am in simulate mode. This is same case with GEngine->AddOnScreenDebugMessage. Neither of those actually draw anything to screen when I am in simulate mode. So I thought it must just be with simulate mode, however when I switch back into viewport messages still don’t print.

Its worth noting that if first time I start it, after loading editor, its in viewport all messages will print. Its not until I press play in simulate mode does it break and not print anything even after switching back to viewport.


I wasn’t able to reproduce this behavior. Where are you printing string? Is Blueprint in level, or is it spawned at Begin Play?

If I understand you correctly, it works correctly during Play, but when you Simulate, it stops working, and then when Playing again it still doesn’t work?

Are you able to reproduce this in a new project? If so, please and attach project (or get us a download link) so we can take a look. Thanks!

So I am trying to print a string from a number of places. I am trying to print one from my AI Controller and also I am using a number of GEngine->AddOnScreenDebugMessage withing my c++ (Granted those could just not be getting reached). And yes, running in viewport it works, then will not work in simulate. Even switching back after running it in simulate will have it still not work.

Okay so I made a new project and did my best to re create this but I cant. I even went ahead and made my own AIController class and my own PathFollowingComponent class and set that up but it still works even when I inherit from those.

What I’m thinking could be problem is that I upgraded project from 4.7 and now I’m working in 4.8.

Also it could be worth mentioning that I didn’t have any problems to begin with until I played project from Visual as opposed to pressing play in editor.

I really don’t see any difference in code or blueprints that would cause my original project to break like it has (beside other classes that have nothing to do with AI stuff where problems are occurring) especially compared to new tester project I just made. Is my only choice here to restart project from 4.8 off get go?


I was working on a bug that seems very similar to what you are describing. Can you take a look here and see if this sounds like what you were seeing?

So yes that is a very similar problem to what I have and pressing (') twice does bring back on screen messages in PIE, however I still have nothing displaying while in Simulate mode even after pressing that twice. :confused:


I’m sorry to hear workaround didn’t work for you. However I do have good news! UE-14330 has been fixed internally and is currently slated for 4.9.