On overlap events not working

I am creating a paper 2d game and the issue I am running into is I have multiple levels on level 1 my collision boxes that kill the player if they fall on spikes water ect are not working on level 2 the player simply stands on the collision instead of taking damage. The enemy overlap events are still working just not basic collisions and the Collison boxes I have set to keep the player in the map allow the player to walk through them instead of blocking. I have gone through all of my settings and it appears that everything for level 2 is set up exactly as in level 1 so I am unsure why this is happening. The damage systems are set to cast damage to player character. Thank you for taking time to look at my issue I look forward to reading the responses.

I figured out the issue with the collision supposed to keep my player in the map just not why the on overlap collision boxes are not working, The level blocking Collison was on the wrong axis but everything is now set to the same y coordinates as the player for some reason I can walk on my overlap collision that is supposed to kill the player.

Ok I created a new level set it up the same and my on overlap collisions are working I am unsure as to what setting cause the issue but I am just going to delete that level and use the new one maybe it was some weird glitch.

1 Like

Did you ever figure this out? I have something similar happening. I’m not sure what changed but now when i fall I walk on the kill box. I was trying to use a health system but i’m not sure if thats it.

Hey there @Ciezzz! There’s a ton of possibilities why your character may not be making contact with your kill-box. The most likely case is that your kill box is set to “Block all” (thus it stops things, but doesn’t call the event) in it’s collision details. You could set this to custom and to overlap pawns. If this isn’t the case feel free to drop us a thread with some more info about your project (including the relevant settings/blueprints) and I’d be happy to check it out for you!

1 Like

When you read tooltip of “Generate Overlap Events” - it needs to be active on both ends

So basically spikes object and the component from your Player you use to check the overlaps - both need this option enabled, otherwise it will not be triggered

1 Like

That worked! Love you guys!!! :smiley :smiley :smiley:
it can get so frustrating learning a new software. Glad i have this community to help.


It may take some time until you will remember it all especially if you’re used to some other Software

Also - read tooltips the Epic Staff left us as very often it provides useful information giving you hints on how you should use the specific Value or System

Example - hover your mouse over the check box with Generate Overlap Events and read carefully - there’s the hint to have it enabled on both ends :wink:

And we’re glad you’ve solved your issue and you can move forward with your Project, wish you the best with it :slight_smile:

1 Like