Old SpeedTree issue still occurring in 4.7

Hey Epic!

Congratulations on the great 4.7 release!

I’ve decided to put a thread here about an issue occurring with the SpeedTree, there been multiple people mentioning it.

This was happening back in 4.5, and the only way is to change things in the materials to fix it. You understand that people who are buying things like grass are not good with materials, so for them is crucial after purchasing something to focus on other things on the engine.

I think a lot of people are afraid to use SpeedTree because of possible poor compatibility in the future.

So, that’s the feedback from me, let’s hope its useful for you! =)

Hmm, still the same problem… → I will also check it in 4.7, probably I can find a fix without changing the material :slight_smile:

It would be best if the import process for SpeedTrees was properly updated to support the new foliage shading model. I don’t see how this was ignored.

Hi sarfios,

If you could, please post this to the answerhub under the “Bug Reports” section at http://answers.unrealengine.com so we can assist you in depth. Thank you!

Sure!

Just did it! Thanks for the reply.

I will just add the link to this thread so that you guys know what we already tried: Speedtree vegetation shader issue ? - Rendering - Unreal Engine Forums :slight_smile:

I’ve posted it
https://answers.unrealengine.com/questions/178112/speedtree-blackdark-sides-of-the-foliage.html

The nice guy explained me that it’s normal, but I Think he misunderstood me and changed it from bug category to using UE4, I tried to explain that the one appearing in the material nodes is the default settings of Unreal Engine 4, not my work :stuck_out_tongue: