Download

Okay.. I'm ready to give up.. I need some help here with my rig.

I’m having a terrible time with rigging and getting my arms to work in ue4.

I did manage to get them into the editor with a bunch of errors though. You can see here I at least managed to get them in haha…

Can anyone make a tutorial to help myself and others out with this? From scratch? Even if you just whipped together some cylinders for arms, rigged it as fast as you possibly could, and imported it into Unreal, it would make this soo much easier. I’m having issues and I don’t have any clue where from. I’ve googled rigging tutorials for arms and I literally just got done watching 3 hours worth of videos about rigging udk related. So I rigged my arms, skinned/weighed them, got it together, tried importing it and got a few errors about minimum bone size too large, no UV’s set, materials isn’t set, and FBX file version.

ANYWAYS…I’m stuck and can’t figure out how to “Properly” get this working. I’d be SOO grateful for a tutorial or even if someone could work with me. As soon as I can get this rigging down and into Unreal I think I’ll be okay for a while.

Am I running into issues because I’m using max?? How the hell does a guy get a rigged set of arms into unreal? lol. Am I rigging wrong? Maybe I’m exporting it the wrong way? I’m very frustrated at this point because my lack of experience is starting to get on my nerves. . ha. I tried a cat rig at first, and went to the old fashioned bone method. I still can’t seem to get any to work. I’ve never used maya and I certainly can’t afford it, nor am I a student. All I have is max 2014. I’d be more then grateful for any help.

I attached my .MAX file for the arms… I’d like to think I’m a good modeler, but I’m still learning everything past the actual model. Anyways, maybe someone can take a look at my terrible rigging and tell me what’s wrong and how to fix it?

.MAX
http://www.mediafire.com/download/y96tppl39z48olk/rigging.max

.FBX
http://www.mediafire.com/download/dixxe5cxyq3lreq/rigging.FBX

3DSMax is definitely not a problem. We use Max at Epic Games all the time. :smiley:

The minimum bone size error may be caused by the scale of your model. If it’s too small, the auto-physics asset generation may complain. This is easily fixable by either scaling up your model, or re-calculating your phat asset with a smaller setting for minimum bone size.
You should add a UVwrap modifier in Max to get some base UV’s.
The FBX warning is a warning, but nothing is going to break because of it.

It looks like you did get the skeletal mesh in the editor! Congratulations. What are you stuck on at this point?

I’m pretty much at the same stage as the author; but I do have one question.
Do I create all my anim sequences in one timeline, i.e walking anim @ 0-10 secs, jump anim @ 15-20 secs, Melee anim @ 25-27 secs??

Some prefer to keep all animations in one time-line. It’s totally up to you. I generally make unique files per animation but I make sure I reference the rig in case I need to make any changes to it. If you aren’t referencing a rig, then you may want to keep them all in one timeline so you can make changes to the rig if the need arises. (ie adding leaf bones like IK, etc)

We’ll take a look. If you could upload your .fbx file that would be preferable so we ensure we have the same exported fbx.

I’ll upload it as soon as I get home from work. I actually purposely left out the fbx because I figured i might be exporting it wrong. I’ll export it the way I did, and upload the FBX in a couple hours. THANKS btw for offering. Really appreciate it. I’ll update it when I get home. This has really been bugging me.

FBX is here and also in the OP.

http://www.mediafire.com/download/dixxe5cxyq3lreq/rigging.FBX

Your FBX file has no deformers. Meaning your bones are not skinned to the geometry. In this case we have to fail the import because we cannot connect a skeletal mesh together without knowing how to weight the vertices to the bones. I’ve verified this by opening the FBX file in Maya and Max. I’ll open your original MAX file to see if there is some export issue.

Thanks. I’m been modeling for years, but I’ve never rigged before, and don’t have maya. So It’s definitely a learning experience. I did skin the bones. I’m not exactly sure what’s going on here. Also, is there supposed to be the root bone like I have it?

I am a programmer not a Max user but I asked one of our artists and he said you have a skin modifier on your mesh but no bones assigned inside the modifier. There are a bunch of basic skinning tutorials I found by googling “3ds max skin tutorial” which might help you.

Select your Skin Modifier, and in the Bones section click the Add button, and then select your bones.

Yea, I would check out some tutorial on using the Skin Modifier. Also, looking at this model, it is pretty dense, so you might want to look into making a lower resolution mesh and skin that, and then transfer that weighting to this model using the Skin Wrap Modifier. Check out some tutorials on that too.

First of all Matt, I really appreciate you helping me out!

Second off, it turns out that I uploaded the wrong max file!! After you told me I didn’t have my bones assigned I figured you ended up with the wrong file… Thanks for pointing that out. THIS is the max file I’m having errors with. Sorry about that. I had saved a bunch of times and got lost in my own naming convention.

.MAX
http://www.mediafire.com/download/59bdrah6bzi4hyf/Human_armsrigged.max

.FBX
http://www.mediafire.com/download/829xb85e3n8fga8/Human_armsrigged.FBX

Hi, something is messed up with your root bone. I replaced it with a new one, relinked the arms to it, and re applied the skin modifier, and it comes in without the warnings accept for ones for not having a material or UV’s, but that is to be expected since this mesh has neither.

I just took a look at the file and there is also another problem that isn’t giving errors but that you should be very aware of. Shane just touched on it, and that is the root bone. It has a scale value and a non uniform one at that. A skeletal mesh should be exported/imported at default scale where the x y z values are all 100. Currently the root bone in your file is 38, 22, 22. Although it looks like your skeletal mesh came in at the right size, if you show bones in the skeletal mesh viewer you will see they aren’t inside your mesh where they should be. Also, to give you an idea of why non uniform scale in max can cause problems, just make a two bone chain in max, a parent bone and a child. Then scale the parent bone on the x axis only. Then try rotating the child bone on y or z in max and you will see it skew. If you want to edit bone size in max, you should always go to the “bone tools” option in the animation menu up top. That allows you to edit your bones without affecting the scale of the bone’s axis.

So I think at this point all the errors have been accounted for? The UV error you were getting was just because you haven’t put UV’s on the mesh. It isn’t going to cause you problems right now to have a grayscale mesh, but once you put materials on you are going to want UV’s. the material error is just that you didn’t have a material assigned. Also not a big deal until you start with materials. The minimum bone scale error is more important. HosFross mentioned it earlier. Looking at your model size it does seem small, although not crazy small. So that one is probably a combination of the wierd scale on the root bone mixed with the already small size. I would make that model bigger if you can.

Thanks a lot for the help everyone. I’m aware of the UV and material errors. That root bone scale is what threw me for a loop. I couldn’t figure it out and the more I messed with it the more things got messed up.

Do I need to have a root bone similar to that (and in the same spot) for my regular full human models as well? I got the model into unreal without any errors now from the help I got from here. I really really appreciate it. Thank you.

I found some amazing tutorials for Rigging, Skinning, getting the mesh bones applied to the mesh.

Wow I am so amazed by the help that the guys at epic have been offering to people.

Just a though but when exporting did you make sure important stuff was checked, like deformations?

Not the first time I’ve over looked that one.

Animation wise I use clips as I use Motion Builder which works best using takes. Walks for example I have an assortment of motion capture clips just on walks alone so I can load them all in and re-target to my rig and export to FBX as single clips based on the name of the take. This way I have a folder containing dozens of animations just on walking alone to chose from. Experience has taught me that what you though would look hot on your player model does not. :wink:

Hello Etirnne, you can create a phys asset with right clicking the Mesh, then there is an option. Also try small amounts like 0.2 maybe (for the phys spheres).