Download

ok mod use to work, so had to make a new one and now I can't craft my new engrams

got my mod to load into single player, learn the engram and head to the crafting window and craft is greyed out. there are no requirements for crafting at all. it works great in the editor just not in single player.
-using the giveitemnum command in the console will give you the items but crafting them only works in the editor


The metal helmet is defaulted to craft in the fabricator, make sure fabricator is not still listed in the “requires inventory component to craft” section of the helmets PrimalItem_BP. That section should have no entries if you are wanting to craft in your inventory.

It also appears that things with no crafting req no longer work. Some have been using the specimen implant as a req, but only allows for one crafting per ‘life’. Others have done 1 thatch.

ok ill try the requirement then, another question: if I create a child blueprint I cannot learn the engram on my server but it I copy I’m fine. Also when it comes to future compatibility with my mod and updates one of the tutorials suggested sub-classing. I’m assuming this meant to use the “create blueprint based on this” option.

Honestly, the way i child things, is copy, then go into blueprint properties, and re-parent it to whatever you copied from. It seems to work much better that way.

reparented and now my armor cant be learned nor received through “giveitemnum”.
do you think it could be the primalgamedata bp needing to be reparented? I used the generic mod one that was suppose to be subclassed to the main one

No, but I would go through and just rebuild your links.

Make sure that EngramEntry is properly linked and verify your file paths.

Reparenting should not have effected being able to give you the item through command.

I have noticed when testing on a server, if I cannot give myself and item, I check the downloaded files from steam and they are always missing, which means I have a broken link somewhere. I start with EngramEntry (in your case, as these are not structures) in PGD, link it again, move to EngramEntry, link PrimalItem_star_wars_gangster_helm or whatever, link that in EngramEntry again, even if they are properly linked, do it again. The editor can be buggy. Then in your primal item, make sure it links to whatever files you gotta have (SM) for your helm.

If you are still having problems, parent it to the file that the original helms are parented to. Open up an original helm primalitem file and compare it with yours, looking at all the check boxes. Not just viewing modified only. A lot of times I forget I am looking at modified only and run in circles for a couple minutes before I realize my mistake.

Make sure the is no crafting inv req for a fabricator or something as well. Give the item a crafting req of at least 1 item. Thatch, stone, whatever. Just make sure its still there, I know you said you have done this. Make sure Give to players inv is checked in EngramEntry.

I figured it out, Had to roll back my server a few days something corrupted the map file. Also I found that the mod files would transfer from steam properly to my client but not my server so I’m just manually loading the files and everything works now

started detailing the helm, sadly half the detail wont show up much in this game. pretty much all that’s left is art finally. Armor is there too, no boots yet but busy figuring out how I want things to look first. some tiny skinning as in animation issues too but that pretty quick mainly a cpl of places at the base of the butt and back panel

oh btw biggest art problem I’m having, well two things: First bloom is nuts on the armor even at lower values of near white, second unreal’s GI ao bake light map like thing, if you zoom in fairly close (separate uv channel for that stuff still didn’t fix, proper smoothing groups and seams) you can see every edge in the mesh darkened and revealing triangles on all the geometry. 3rd issue now that I think of it, metallic/roughness maps arn’t doin nearly as well as they do in substance, seems to be a blanket reflection/ spec cross parts I specifically painted to have variation in that information.

lastly thanks to all that have responded, felt like I’d be doin all this art and not be able to truly share it on my server without your advice

I could always use an Altimeter off-hand mesh and ani for my mod! :slight_smile:

I can’t do that stuff. 0 artistic skill. My stick men throw themselves in the trash.

current painting prcess, new to substance painter an figuring out how to transfer to the rest of the armor, have substance designer too
http://steamcommunity.com/sharedfiles/filedetails/?id=511043949
that mod is the old one but I use it to update ppl on what im doin with p0k3r and flannel now, specifically through comments

eff940299e7f6b8946db7fbe788b1f2535921130.jpeg

I’m not sure I’m understanding the material instancing, my armor looks better now but I don’t want it to look like steel, so even with my metal roughness combined map its very metallic, I tried inverting and it loses all specularity. what I’m going for is more of a plastic substance. everything looks great in substance painter I just don’t understand how to plug into their material system properly.

ha I figured it out http://steamcommunity.com/sharedfiles/filedetails/?id=572477559
ill be sharing soon with ppl what I did on here once I ensure I understand more of it. there are some tweaks that still need to happen doesn’t feel like the values match between substance and the game. not drastically as before but minor tweaks needed. then its on to what I want for colorization, then tweaking skinning for the animations, well and refining some of the models/ building a true fpv one