Download

Odd smoothing on FBX from C4D

Still new to Unreal but have been using C4D for quite some time. I am aware of the “no smoothing group information” and “Face material index inconsistency” issues that show up in the message log when importing an fbx from Cinema. For the most part my model has imported with correct smoothing, except for a small area that seems to not have it at all. Attached are screens of the issue in Unreal and what my model looks like in C4D

Screen Shot 2016-07-15 at 3.54.02 PM.png
Screen Shot 2016-07-15 at 3.55.29 PM.png

I have my export settings from C4D using the 2014 fbx format. My phong tag has Angle Limit and Use Edge Breaks checked, with the Angle being 88°.

When I import into Unreal I am just using the Import Normals method (Normals and Tangents seems to destroy the smoothing) with my fbx Export Compatibility set to 2014 in my preferences.

If anyone has an idea for a work around let me know!

Use the fbx 6.1 2010 version for exporting to UE4, it’s much more compatible.

The “no smoothing group information” message will always show up except if you use Cactus Dans fbx exporter.
Still smoothing should be ok if you set up everything correctly.

“Face material index inconsistency” is really an issue that will become important as soon as you try to Use multiple materials on a mesh.
Luckly that issue can be resolved by changing the order of the Tags. Put the Material Tags in front of everything else and it should be gone.

I’d also recomend you to triangulate your model for export and make sure that smoothing looks exactly like you want it.
Best solution IMO is to bake the smoothing with a plugin called Vertex Normal Tool.

There’s a free and also a “pay what you want”-Version of it available.

If this still doesn’t fix your smoothing, the issue lies elsewere like in your model, uv map, texture and or baking.
In that case i need more information e.g. the mesh itself or at least screenshots of every vital aspect e.g. UV map.

Thanks, I will look into making those changes and the plugin to see if that clears things up!