Oculus VR Plugin Missing in Project Settings Menu - Intended Quest Development

Hello all,

I am trying to make an app for Oculus Quest using Unreal Engine and the Oculus VR plugin while developing on macOS. I wish to access the settings of the Oculus VR plugin in the “Project Settings” panel in the “Plugins” section, but the OculusVR item does not appear (see first screenshot below) even though the Oculus VR plugin was enabled in the “Edit->Plugins” menu (see second screenshot below).

https://timart.me/img/oculus-vr-problem.png

https://timart.me/img/oculus-vr-problem-2.png

The expected appearance of the OculusVR plugin settings are described in the [Oculus plugin for Unreal Engine guide][3]. I have followed all preliminary steps listed in [Oculus’ quick-start guide for Unreal Engine development on Quest][4].

I have experienced this behavior with both the Unreal Engine editor binary download from the Epic Games Launcher, as well as from the editor I built from source using the Oculus-VR Unreal Engine repository.

This same issue has been pointed out in other posts and forums ([Ex 1][5], [Ex 2][6], [Ex 3][7], [Ex 4][8]). The solution mentioned in a couple of the posts is to [download the Oculus Rift software][9], but this software only supports PC and not MacOS, so I am unable to use this. Surprisingly, this solution worked for PC users who were not attempting to develop for the Rift, but instead for the Quest. Another partial solution mentioned, which only allows you to modify the FFR setting for the plugin, is [explained at the bottom of an Oculus guide][10].

Is there any known full solution to this issue, specifically when developing on MacOS? I assume it would be simple enough to see the plugin settings for a plugin which has been enabled in the Unreal Engine editor.

Thank you for any help on this topic.

See duplicate post on Oculus Forum (sadly without all the helpful links):

Hi Tim,

I’ll start by saying I develop content on the Quest using Windows so i cant be exact when it comes to helping. But I run a Discord with quite a few Quest developers. I no there is someone in our server who uses there mac for Quest development but they had to install Windows on there machine and do a duel boot system so they could install the Oculus Software as this i’s something you do need installed i belive, I could be wrong though.

I no its not the best or most efficient solution but it does work if you have the free memory to do it. If you want somewhere to hang out and chat Quest dev i’ll leave a link to the discord bellow.

Hope this helps,
Jonathan

i had the same problem on windows but when i enabled the oculus avatar plugin the settings appeared without installing the rift software

starting with 4.26 avatar plugin is no longer part of UE

BUT, after much running around i found the way to get the settings menu back:

connect your headset (and confirm in cmd console with “adb devices”)

Are you using the Oculus source code or the Epic Unreal Engine distribution? Were you able to achieve this on MacOS or was this on Windows?

this was done using the standard UE distribution, on windows. my apologies for not mentioning the cross platform.

the problem started when i tried loading a 4.13 project in 4.26

it doesn’t matter, as you’re dealing with Android.

Regardless of platform, Android (for Oculus Quest) or PC (for Oculus Rift), there are settings in the Oculus VR Plugin menu that deal with any Oculus VR experience. For example, the splash screen settings allow you to setup an Oculus specific VR splash screen.

From discussion in the Oculus Forum: Oculus VR Plugin Missing in Unreal Editor Project ... - Oculus Community - 754870
We believe there is not currently a solution to this problem for MacOS. Apparently the visibility of these settings is tied to the Oculus PC Runtime which only runs on Windows PCs via the Oculus PC app.

Just shouting into the void here about how ■■■■■■■ stupid this is. This one issue has stopped me dead in the water. God I hate facebook.