[OCULUS] Unreal Engine not detecting Oculus GO device

My system is brand new Win 10 pro, Unreal Studio 4.21.1 with Codeworks 1R7u1 standard install, usb drivers v2 from Oculus site - adb list the device, but Unreal does not detect it. How can I make Unreal detect the GO? Can I manually add it?
I have read older posts with the same issue, but found no solutions. Can anyone help?

Did you go through the setup steps in your Project Settings? In particular, did you set your Go into development mode? Can UE4 see the Android SDK properly? (green indicator)

Thank you for your answer.
Yes, the Go is in development mode ( I have had a successful launch from another computer) and I get green indicator from UE4 on the Android SDK.

So this is happens only on a single computer? I would attempt a repair of the engine, assuming you are using the Launcher version.

I had similar issues and almost gave up. Not entirely sure what I did, but by chance found it to work out of 4.19. I seem to remember doing a full android works install and the ADB drivers.

My only problem now is getting the Oculus controller to work in my scene. Its a shame there isn’t a template setup for this like the Rift or Go. I don’t believe the SamsungVr controller works in the same way.

I think I’m jinxed. It also happened on a third computer.
I have reinstalled UE4.21.1 on two of them but the Go is still not detected even if adb lists the device on both computers.

I am still having this problem - can someone help?

From the Oculus app on your phone, connect the Go, then go to settings, and disable the “Enable Developer mode”, and your pc should list the Go as am external hard drive.
Now try to enable the “Enable Developer mode” again, wear the Go and you should have a message on scree, asking about authorization ( or something like that ), so say yes/authorize, and then start your UE4 scene, and you should be able to build/deploy on the Go.

Did you ever find a solution for this? I’m running into the same problem right now, having followed all the steps.

Do you have Java installed on your computer ? it fixed this problem for me (I finally could see the oculus on the launch panel, but the launching itself still does not work aha)

Installed Java, did all the things, no mention of ‘Oculus Go’ anywhere in the Unreal Editor. Sigh. It does work when I launch with Daydream selected in Project Options, but this doesn’t really give me the confidence it all works like intended.

Finally solved it by building the latest version of the editor myself.

I think you couldn’t see it because the unreal launcher calls it “pacific” and not “oculus go”.
Did you finally managed to launch something ? Is it working correctly ?

Same problem here. Did anyone find a solution?

hello, i am having a very wired problem!!! my oculus go connect properly. all the instruction i follow by the documentation. but when i lunch my application it is finishing without any error but when i have a look into headset!! its wired it is a single screen!! i cant even look at it with my both eye…please can someone explain what happening? i have oculus rift installed on same pc and rift is showing it well.

Make sure you are following all the settings/required described here:…t-guide-quest/