Oculus Touch Controller trigger cap-touch not working

The trigger capacitive touch event or value does not work. I’ve tried both the one under Action Mappings and the one under Axis Mappings. I’ve also tried under Tick to add a node that reads the value of the trigger captouch (the one found in Input > Gamepad Values when you right click) and print out what that value is. It remains at 0.0 all the time.

My capacitive sensor on the trigger is not faulty as it works in games (including Robo Recall), so I’m not sure where the problem comes from. All other captouch events except the trigger seems to work properly.

Hello Acriax,

I was not able to reproduce this issue. Is there any more information that you could provide?

Thanks,

Lily

Hi again, after testing more now, I managed to figure out what caused the issue. I had mapped Oculus Touch (L) Trigger CapTouch as an Action Mapping in the project settings. Since it’s either 1.0 or 0.0, I figured it would make more sense. But it seems mapping it to an Action Mapping makes it stop working as an Axis, and the Action Mapping input event for it never fires as well. So the solution seems to simply use it only as an axis and not as an action.

However, it is a bit odd that the other CapTouch inputs work as Action Mappings.