Oculus Quest Web Browser

I’m trying to interact with a web browser widget, using the widget interaction component, works on PC, doesn’t work on the Oculus Quest.
**I simply need to be able to interact with a browser widget on the Oculus Quest. **:slight_smile:

Do only accept this mission if you really know how to make it work (that means you probably have an Oculus Quest).

We can work directly (discord + bank transfer in any currency) or through Upwork (https://www.upwork.com/jobs/~01cdb242eaa77fa5b8)



I’d Glad to assist you.
PM Sent, Please Check.

Very Best Regards

when u mean it works in pc , does you mean that its work in Oculus but not working in Oculus Quest ?

I haven’t tried on Oculus Rift. It works on PC in the editor with a mouse and keyboard. It doesn’t work on the Oculus Quest.

Hello, I’m encountering the same issue as Loeizd, I’m testing on Oculus Quest, but I really need this for Oculus Go. What would it take to hear the solution to this issue? Feel free to PM me.

I had two issues actually:

  1. impossible to click on the browser: solved by injecting javascript to click (there’s a BP node for that)

document.elementFromPoint(x, y).click(); 

  1. browser rendering size is capped at 500x500px, no fix for this one

Nice find! That’s going to be extremely helpful.

I have been experimenting with this widget a little bit. It appears that the rendering size is tied directly to the widget component’s draw size.
When I render the widget as a component of an actor, notice what happens when I change the widget’s draw size:

If I have time, I’d like to see if I can make some kind of “zoom” functionality either by hacking the web widget or by making an actor that shrinks as its UI draw size increases.

Could you get the browser widget working on quest2? All I could get was a black screen, so far. Any tips?

Did you ever get the browser widget to run on the quest2? I am experiencing a black screen when running in opengl and a white screen when running with vulkan.

It doesn’t seem to work on Android…

Wondering if anyone had any resolution here. I’m testing on 4.27.2, just basic level, web browser plugin enabled, web browser displays a page fine in the editor, or playing with normal VR headset attached or built to desktop VR. When Built and deployed on a Quest or Quest2, there is no content displayed. Reading through the forums I can’t seem to find a definitive answer as to whether or not its possible to use and view websites from an Unreal Engine built project. Or if Unreal doesn’t support that for Quest and Quest 2 .

1 Like

Bump here looking for a solution for that; anyone successfully made the WebBrowser plugin work on Oculus Quest 2?

1 Like

Have you find any solution . i am stuck in it .

The only solution I found is that UE5.2 seems to have fixed the issue but I can’t build UE5.2 from github, getting errors. So I will try to build UE5.1 from the source but using the WebBrowser runtime resource of UE5.2 to see if that works…

FYI, here is the fix according to unreal engine trackers issues: Unreal Engine Issues and Bug Tracker (UE-150021)

useless project a Web Browser nuts money waste…Virtual Desktops makes any browser senseless and in the future everything will be virtual

why don’t you make a nice VIrtalSpatphone so people can have their phone on a window inside the VR answer the Cursed phone without closing the VR you ask 15$ for each copy you buy yourself a catamaran and tropical island…

there are people who have 10 phones put them all inside a VR headset sia product…a bisnes product

Did this work for you?

did you found the way to click the browser?