Download

Oculus Quest Antialiasing

I’m packaging for Oculus Quest, in android, all work fine but I have problem with antialiasing and jittering. I wanto to inprove MSAA and/or resolution. I tried all, with consolle and device profile…but nothing work.

Please help me

Regards

Hey there, try to increase the vr.pixeldensity to 1.25 or 1.5 if you can, thats the only thing I found to improve the AA.

Ok, but where? In console? In level blueprint? In device profile? Thanks!!!

Run a command via blueprint at startup or add it to the .ini

Maybe you could try this again, under device profile.ini file add in this two command r.MobileContentScaleFactor=0,r.DefaultFeature.AntiAliasing=2

Then enable Forward shading renderer.(MSAA only work with forward shader!)

To use Multisample Anti-Aliasing (MSAA):

  1. In the Edit menu, open the Project Settings.
  2. Select the Rendering tab on the left and locate the Default Settings category.
  3. Set the Anti-Aliasing Method property to MSAA.

This should work on android and improve the AA,r.DefaultFeature.AntiAliasing value can be set higher if needed . (I tested on a SD820 Phone, Exynos Samsung galaxy S9, SD 855 Phone). Good luck and I hope it works for you too.