Occasional crash when starting project

Sometimes when I start my project now I get a crash with the following situation. Not always and I can’t really say what triggers it. it seems to me sometimes it happens and most of the time it doesn’t without me changing anything

Hey -

Does this crash reproduce in a new empty project? Can you post the log files from the crash? Also let us know if this crash occurs when running the editor itself rather than running through VS debug mode.


link text

I uploaded the log file. These crashes happen every few starts here in my project. It’ doesn’t happen in an empty project. If you want me to check some things here in the debugger, let me know what you want me to do. Since it happens sevral times a day for me, I will be able to help with debugging

You could run a map check. I was planing for a log on what went wrong. All this tells me is how the game was operating.

I did a map check on all 3 maps I have stored so far and all say “no errors”

Does the crash occur when not running in debug mode (double click on the .uproject to open the project directly)? As 1999 mentioned the log that you posted doesn’t show where the crash is occurring. If this does happen outside of VS debugging can you post what is provided in the Crash Report window as well as the Log file after the crash?

Dang, I did what you said and it crashed and I clicked on “Send info” and the window disappeared. I hope you can find the crash report somewhere in your system?

The funny thing is, it appears nearly reliably the first time after I turn on my computer and load the project. I do that in VS but today, following your instructions, I did it outside of VS and it crashed too.

After the morning blues, it happens sporadically during the day. I hope you received the crash report through your upload system. If not, let me know and I try again and will this time copy paste the text from the crash window

I just found the logfile was saved including a minidump. I sent you a link to filedropper with the zip file in your Forum account

It seems to happen every time (or most of the time) after I restarted VS, the Windows start has nothing to do with it. The first I run the program in VS it crashes, after that it mostly works.
I tried to start again from the UE project file like you said and I had a similar result. First time, it crashed just like before, second time it worked.
The second time I got a warning after loading
LoadErrors:Warning: Warning CreateExport: Failed to load Outer for resource ‘ChangeMapScreen’: BlueprintGeneratedClass /Game/Client/Blueprints/MikaboshiGameInstanceBP.MikaboshiGameInstanceBP_C
but other than that it did not crash the second time

The more you can replicate the crash and get a error log the more of a i dear of what is going wrong you have. “/Game/Client/Blueprints/MikaboshiGameInstanceBP.MikaboshiGameInstanceBP_C” So what is in here that could be causing the crash?

the problem is more, why does it happen predictably the first time I run my project but not l;ater? that’s the mysterious behavior. But I set a number a number of log statements in the game instance class and will check to see which ones are carried out and which not, if there’s a problem in the Int() function, that should give me an idea at what stage of the initialization.

Since the warning referred to the MikaboshiGameInstanceBP could you post a screenshot of the construction graph? If the crash is on project open then it’s likely that something is trying to access information that doesn’t exist yet. Additionally about the crash report that you submitted, What is the name of the project and did you write anything in the description box? This will help me find the report in our system.

My game instance BP is really empty except one variable. It is based on a c++ game instance which does all the work. I sent a link to the sourcecode of my game instance to your Forum account. Hope that helps, although there is not much going on in the C++ initialization part either
Regarding the crash upload, no i did not write anything in the descriptino since I clicked the sed button as reflex without thinking. But I uploaded the minidump and sent you a link to your Forum account.

When starting outside of VS I get this popup message with a warning:

LoadErrors:Warning: Warning CreateExport: Failed to load Outer for resource 'ChangeMapScreen': BlueprintGeneratedClass /Game/Client/Blueprints/MikaboshiGameInstanceBP.MikaboshiGameInstanceBP_C

But there was no crash. ChangeMapScreen is a UMG based screen that I popup at times but this message comes during Editor start when my game code is not active yet. I dont understand what this message means but perhaps it’s related

Is there any thing in you blueprints or C++ class that is called “ChangeMapScreen”. This could be caused by something that links to your classes.

Yes ChangeMapScreen is a UMG widget that is brought up while a map is loaded. It is referenced in my MikaboshiGameInstanceBP class, but there is only a reference variable to ChangeMapScreen and the gameinstance does not attempt to create a changemapscreen, so it’s really just an empty variable that should be initialized to null at startup

I went up in the stack during one of these crashes, and the crash occurs when loading U64Editor-MediaPlayerEditor.DLL so it has nothing to do with my code I assume. I wish I could see the error message but the last three steps on the callstack are grayed out and there is no source code for this code in the DLLs. Apparently the crash happens in the destructor of an FText but I cant the text.

I checked it again with another crash and it definitively is loading that media player DLL when it crashes, so that should give those who know the internals of the engine an idea about the timing of the crash and whether or not any of my code can be involved

Hey -

I have not not been able to reproduce the crash you describe on launching the project. Are you using any form of media player asset in your project (such as an intro video when the game is started)? Do you continue to get the crash if you remove the reference to ChangeMapScreen in the MikaboshiGameInstanceBP? If possible could you upload a copy of your project to drop box and send me a link to download it so that I can test the crash directly? If privacy is a concern you can send me a PM on the forums with the link.


I don’t use the media player at all. I just sent another crash report from the report window at startup with all the included info. I added some text for the report so you can find it easier, I included my login name in capital letters.

I dont understand the error messages at the end of the logfile. All those items that are named there as “not found” are clearly in my project! When I run the project for the second time, everything is found!

It is basically as if my code/Blueprints are compiled in the wrong order at startup and after that, they are buffered. As if the project files in a C++ project don’t know all the dependencies and report a missing link object and then the second time you run make, the missing things are compiled from the first run and are available fro linking, if I may use an analogy.
For instance this one line from the logfile:

[compiler MikaboshiGameModeBP] Error Could not find a function named "Get_Next_Popup_Message" in 'MikaboshiGameModeBP'.
Make sure 'MikaboshiGameModeBP' has been compiled for  Get Next Popup Message 

The given function is there! It works! and the second time I run the program, it all works fine. It’s like the loader/compiler wahtever it is that does your internal translation, does not see this the first time, but apparanetly continues to run and translates it so that it is available the second run.

I add this comment for now and will see if I can strip down the project enough to send it to you.