Objects rendering in preview but not sequencer

Has anyone run into any issues with sequencer inexplicably not rendering certain objects when trying to out put a video? I’ve attached some example screenshots. It’s mostly fine but the two arches in the background don’t render.

Do the arches disappear if you Simulate In Editor while playing your sequence? Only thing I can think of is the “Hidden in Game” setting on the assets, or maybe a rogue spawn or visibility track in your sequence. Sorry if that’s no help. I mostly just wanted to reply to say that your art style looks really cool!

dope non photorealistic renders.
if it’s in a level of it’s own maybe you don’t have it set to load.
that’s the only thing I remember bumping into as a render issue
or maybe just restart

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-tempid”:“temp_165950_1559606161346_143”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

I have run into this as well. but have not figured it out yet.

try to click “play” your level and click main sequencer camera and try to see your differences in viewports and play window (everything that is visible in this window will be on render). But it is not exactly. Similar in my practice was solved in that way.

Any news on this issue? Anybody solved that?
Having the same issue on 4.26, viewport preview works like perfectly, but once rendering after some frames everything disappear, only the sky remains visible for me

This is a serious issue. After doing all the work, when using Movie Render Queue, the object disappears. Tried all options like Key framing the visibility, re-loading the object in to the sequencer (even though it is not required), the object is missing in the render. (and occasionally it renders in the sequencer render when rendered directly)

I am having the same issue. I have an object that shows up in the viewport but when trying to render to a sequence, the object is not there. I can see the object while in play mode as well, but it just won’t show up in the render sequence.
Running Windows 10 using UE4 build Version: 4.26.1-15228867+++UE4+Release-4.26

did you try changing the bound scale of the objects? higher than 1
like 100?

Hi, I’ve encountered exactly the same problem, what I create and see in my viewport is different from the final rendering video, especially for the lighting effects or VFX and especially when I put many assets into my scene, but I don’t know why, is it just because there are too many assets in the scene? have you figured this out? Looking for help, thanks.

HI GUYS JUST SOLVED! Go to the asset, double click on it will open its properties, then go to its LOD /section /screen size - the ones not showing on the render will be “0,00” just change it to “0,05” and it will be on the render!!!

3 Likes

I’m still having this issue with nearly all my assets (thousands of them) but then a few random assets show up fine. I’ve tried what others have mentioned here, but nothing is making them show up in my cinematics or when I hit play. Everything shows up perfectly in the preview though.

Do you use any sublevels? If so make sure to set their streaming to be loaded, not blueprints.

Yeah I already checked that and these other settings:

Default Streaming Mode = Always Loaded (on all levels)
Details/Rendering =True
Details/Actor Hidden In Game = False
Details/LOD/Include Actor for HLOD Mesh generation = True

I had the same problem, but in my case, I found out that the animated mesh I imported was with switched on Physics and Gravity, so when I started rendering the sequence my mesh just jumped out in an unknown direction and I didn’t see it because it’s starting position was outside the frame. Just that simple :slight_smile: Hope it will help somebody

1 Like

Check if the screensize of to mesh is not set to zero.

Blockquote HI GUYS JUST SOLVED! Go to the asset, double click on it will open its properties, then go to its LOD /section /screen size - the ones not showing on the render will be “0,00” just change it to “0,05” and it will be on the render!!!

This worked for me! Thanks man!