Objects can be seen in dark

1)So as you can see, my objects can be seen in the dark. What should i do?

2)Also i’m getting errors like “static mesh actor has null staticmesh properties” and “invalid lightmap settings”. I checked in properties but they have mesh and right lightmap settings.

3)Aaand the last problem, after getting overlaying uv errors (apart from invalid lightmap error), i did second uv things in blender like they say everyone (there was even a youtube link). But after i did that, my mesh(es) deformed.

It looks like the problem you have is that shadows aren’t being casted on those objects. there could be many reasons for this such as:

  • Lighting hasn’t been built yet
  • The light(s) aren’t casting shadows at all
  • The objects aren’t “receiving” shadows
  • The “room” mesh isn’t casting shadows
  • There is no geometry casting shadows(faces need to face a light to cast shadows, unless they have a double sided material)

We will need more information to be able to narrow down where the problem is. Could you tell us what you have tried so far

As for the second error. does it say which static mesh actor is having the problem?

And the las error, “deformed” is a vague description again can you elaborate on what the problem is. maybe some screenshots?

This is a little room with six box brush cubes (walls, floor and roof made with bsp). There are no light except directional light (default sky light which is at outside) and there are no spaces for it to shine in. But, i placed a cube (not bsp) center of the room to see where the light coming from and it turns out it was coming from directional light! So i put lots of walls (static mesh from starter pack) around cube with each different shadow and light settings. Still, light passes all of them.

I even made another empty room from wall meshes (from starter pack) and there was light inside it too. I opened tutorial projects, made a room and they had the same thing too. does directional light pass through everything? And i rebuilt light in every single change i made to see results. Only bsp boxes aren’t showing in dark.

For second error, i found the solution. There were some meshes in map (which i deleted from editor without removing them from map i assume), i deleted them from map and problem was solved.

For third problem. Think a cube, what i mean deformed is that cube look like it was punched many times (couldn’t take screenshots sorry).

edit: i found that if there is no visible light in the room, directonal light automatically shines in. and i need a complete dark room. But in the next room, there will be light so i need a dark room without deleting directional light (sun’s light).

did you check whether or not the light is casting shadows? also check the mobility of the light. if you are using static lighting then the light will need to be static.

if its happening across all projects then it is most likely something to do with your PC have you got shadows turned off in the settings?

i checked shadows too. it only gets dark if there is another light. like, http://tinyurl.com/kd5po3s . if there are no lights, directonal light kicks in the room like the first picture i posted.

by the way, making directional light static from stationary, made room complete dark. it is worse in quality (made a hole like in the link and look) but it is better than nothing i guess. hope they do something about stationary light bug.

Thank you for your time and answer. I’ll use static for time being. (are they any serious cons for static directional light?

You mention things regarding your lightmaps. Can you post your static mesh settings in your mesh editor. (Open Mesh Editor > Details panel on the side > Static mesh Setting > Click the little arrow to expand settings as well)

Here we can check that your lightmaps are being setup and assigned correctly. Default is set to 0. If you have a second UV this should be set to 1. The lightmap should also have no overlapping faces to prevent any baked shadow issues.

The lightmap resolution should be a default of 32. You would probably want a higher lightmap resolution to get better results.

I want to discuss this option as well that you mentioned in your last post:

by the way, making directional light
static from stationary, made room
complete dark. it is worse in quality
(made a hole like in the link and
look) but it is better than nothing i
guess. hope they do something about
stationary light bug.

Thank you for your time and answer.
I’ll use static for time being. (are
they any serious cons for static
directional light?

Stationary Directional lights by default have no dynamic lighting portion automatically enabled. When you build the lighting everything is being built as static lighting. You will need to go into the light sources details panel and adjust the Stationary light dynamic distance from 0 to some other value that works for you. This will give dynamic lighting when you’re within that unit range. Outside of that range the shadows will be the static baked shadows.

The next thing is when you set all your lights to static only they are just that, static lights. There is no dynamic element to them and anything that is movable in your scene (ie. Physics objects, Characters, etc) will not be shadowed.

Let me know about the first information and I can help you get this fixed. This is not a bug in the system, just needs some setup. :slight_smile:

You can also feel free to check out the Lighting Troubleshooting and Tips guide that Eric and I have been putting together here: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

There is still more to add to it, but it’s got a good start at the moment with some of the more common questions and setups regarding lighting in UE4.

I’m sorry i didn’t mean to spam. They said to me “if you think this is a bug, you should post as a bug section too.” that’s why i did the other question.

I can’t upload pictures (it gives me error) but i triple checked and UV maps index at 1 (i have a second uv map and there is no overlapping). Resolution is at 64.

Making light dynamic distance from 0 to 1000 made the room complete dark.

So should i use stationary or moveable lights for better gameplay experience (point, spotlight and others)?

Thanks for your answer and again, sorry for spamming. I still have much to learn and it is so scary.

No worries with the spamming. It happens. It just better to post once in the relevant section, even if it’s the Bug Report section and you’re not sure. We will move it out if it’s not actually a bug.

With pictures sometimes it will give an error uploading. We’ve had our web team looking into those issues that happen occasionally. Also, make sure that the image is below the 5.2 mb cap otherwise it’ll throw an error as well.

So should i use stationary or moveable
lights for better gameplay experience
(point, spotlight and others)?

My suggestion with this would be to use what works best for your workflow. I don’t like to tell anyone they should specifically use one or the other. They both have their advantages and disadvantages depending on your needs. If you don’t want to use lightmaps or setup custom UVs for lightmaps then Movable is the way to go. If you don’t mind setting up and using lightmaps and you want to have something that 's not as performance heavy by using baked lighting with dynamic lighting then Stationary is your light type.

There are more factors that go into each than just these though. There are plans for an entire lighting video series of tutorials from Epic to be worked on soon!

I cant view the attachment for some reason. but i think the darkness you are referring to is because you have not built the lighting yet so there is no indirect lighting applied. you can either build the lighting or use light propagation volumes for dynamic global illumination.

I’ll check out the link. Thanks again.

I understood, thanks. I will watch videos when they are available. This can be marked as resolved.