Objects are invisible unless selected after editor crash.

The editor crashed and I restarted it, after which when the editor got done loading my entire level was invisible apart from the Skybox. The only way to make objects visible again is by selecting them. But when I deselect them they will just go invisible again. Furthermore, gizmos are always facing the Z+ (positive Z) axis. Objects are also rendering in the order they appear in the World Outliner, when they are selected of course otherwise they’re invisible. Dragging in new objects doesn’t work, they’re also invisible and render incorrectly. I’ve tried restarting the editor multiple times.

Another oddity, the objects aren’t invisible in Unlit mode, but still render in the World Outliner order. It also doesn’t matter how the editor crashes, it has happened twice now (in 2 different projects) the first time after trying to undo something, the second time after attempting to add a mesh from the free Mixamo characters to the level (the Vampire), though I think it would have happened with any mesh.

I would upload the images directly to this question, but that doesn’t seem to be working properly either…

Gizmo bug:

Invisible objects bug:

Anyone? It’s impossible for me to continue working on my game if the world is invisible no matter what. :confused:

Hi Sneggledex,

If you create a new project does the editor do the same thing with the editor gizmo’s? If the issue isn’t happening or is still please let me know.

I’ve not seen this before, so at the moment I’ve got just some common suggestions to try to see if this resolves the issue for you.

  • Make a copy of your project folder and delete everything except for the UProject file, Config, and Content folders. Then open this project and see if the issue is still happening.
  • If that didn’t work go to C:\Users[Your Computer Login Name]\AppData\Local\UnrealEngine Once here make sure the editor is closed and delete all the files here.
  • If that doesn’t work, Make sure the Editor is closed then open the Epic Games Launcher > Library > select the small down arrow next to Launch and select the option for “Verify”
  • If that didn’t work. Uninstall the Editor and do a full reinstall. This will not affect your project folder if you uninstall the editor.

Let me know if any of these get it working for you.

Thank you!

Tim

The issue seemed to have resorted itself, to answer your question if the gizmo issue happened in a new project as well, it didn’t. Even the invisible bug was localized to the projects wherein the editor had crashed.

I went ahead and marked this as the answer since it’s resolved itself for the moment. Should the issue return please let me know if any of the steps above worked.

Thank you!

Alright, will do. For the moment everything seems fine. Maybe it was a one-off thing? Who knows… Anyway thanks for your support Tim.

The issue has returned, and I’ve tried every step you’ve listed. Nothing seemed to have worked. New projects don’t have the issue, however. Problem also persists through PC boots.

Since this doesn’t really seem to be something that is reproducible really would you mind sharing the project and I can go from there to see if there is anything that may resolve the issue or at least see why this may be happening? If you’re willing to share and it’s a larger project can you strip out anything that is not needed to see the issue and post a link here or send me one privately via the forums?

Hey Tim sorry for the late reply, some personal stuff came up here is the project, I’ve left out the Intermediate and Saved folders. MEGA

Hi Tim, any news on what may be causing this and how I can prevent/fix it?

Has anyone solved this yet? I just encountered the exact same thing, and it’s freaking me out.

Nevermind, figured it out. Turns out setting the Near Clip Plane to a value of 0 causes stuff like that to happen. Set it to 0.1 and it’s fine.

Yep it does indeed. Figured this out a while ago, and posted a bug report about it on a different question. Also, next time you should post as a comment instead if its not an answer to the question. :slight_smile:

Ah,yeah. Oops. Well, at least it’s sorted for everyone now.

Thank you so much for posting this, I was just about to have a heart attack because this happened with my uni project and I was so lost on how to fix it!