Object Shaking

Hey, I encountered the same problem yesterday and found that this solution that worked for me.

  1. Open your floor objects static mesh
    - You can do this by clicking on the floor object in your Viewport or in the World Outliner and then selecting the
    - Under the Static Mesh drop-down, double click the thumbnail
    - This should open another window
  2. Scroll down to Collision and change
    the Collision Complexity drop-down to
    “Use Complex Collision As Simple”
  3. Also change the Collision Presets
    drop-down to “Custom…”
  4. Save the static mesh and run the
    scene again, the shaking should be

Hopefully this fixes it for you,

Thanks! Anyway i decided to remove every collision on the mesh and disabled use collision under the LOD0, then added a simplified box collision. Both methods are valid but in this way you’ll lower even further the memory usage of the mesh. Really thanks anyway, i got stucked on the pawn that i didn’t think about checking the floor collision.

I updated the engine from 4.16 to 4.16.2. Now when i preview the level, when my pawn collides with the floor, the root component, the collision sphere, starts shaking up and down and its transform values seem to go mad. Why is that and how can i solve this? If i disable simulate physics it doesn’t shake anymore. I thought that maybe it could be something with the constraints since i saw that something changed in the editor. Please help.

Hey, i don’t actually know why this worked, anyway, the difference is the number of details, the simple collision of the floor has only 6 faces meanwhile the complex one has a lot of them. Complex collision cause more difficult calculations that the physics engine must handle.

Hi! I am sorry for posting in this old question, but I had a similar problem. And while your answer helped me fix my problem as well, I don’t understand why it worked. The Complex and the simple shapes of the floor seem the same, so I don’t understand why this fixed the issue. Could you help me?

Well, thanks anyway! I might try asking about this on the forums.