Object doesn't rotate around its pivot in Sequencer

I’m having a problem with rotation of object in a short animation inside UE4’s Sequencer.

It needs to rotate and pivot around the center of its base: when I set the pivot of the object to the center of its base and rotate it with vieport’s object rotation tool all goes well as expected in the viewport itself.

But once I am in the animation in Sequencer and try to rotate my object there with the object’s transformation Yaw control (equivalent of Z axis - that is the vertical one, right?) viewing Sequencer output in the viewport (clicking the small camera besides the camera object line in the Sequencer) my object’s position is flying all over the place as it does not rotate around its pivot center although I set it in the center of its base - it looks like it is orbiting around some fictional center point way off from my object, so my object is making strange circles instead of rotating around its base on vertical Y (Z in UE4) axis.

Does anyone know why is this happening and how to fix it, that is how to make Sequencer rotation values behave exactly as the rotation tool in Viewport?

1 Like

I’m having the same issue in 4.26
I’ve tried unchecking “Record in World Space” and “Remove Root Animation”
I’ve tried combinations of these.
I’ve tried the take recorder, but I get the same rotated and shifted results.

In attempts to correct these rotations, I’ve added another transform track in sequencer and oriented the mesh so the animation looks correct. However, the mesh now pivots at a different point and moves in arcs as the OP mentioned.

You can see in the capsule component, how the mesh is shifted.

After Unreal has demonstrated the power and merits of sequencer and high quality render queue, it’s frustrating to find that I can’t record physics based, user input, or procedurally generated animations in my project.

The example I’m including is simple character movement without animations to simplify and illustrate the transform issue.

[demonstration of viewport sim and sequencer recording][1]

I’m having the exact same issue with our project. The sequencer records every realtime movement, inputs and animations, but on playback the object is rotated 90 degrees and offset. Readjusting the rotation and offset doesn’t work (at least for offset), as the point of origin is wrong making the object rotation happen behind the character.

If anyone from the Unreal animation team could chime in, it would be very helpful!

did you model your skeletal mesh in blender by any chance?

Nice pics ))

No, we use Maya for modelling/animation. I use Blender, so I’ll do some testing to see if the same problem is there with Blender exported FBX files.

No, we use Maya for modelling/animation. I use Blender, so I’ll do some testing to see if the same problem is there with Blender exported FBX files.

Hello, same problem here (I think?). Did you figure it out? Or just an Unreal Engine bug? I’m trying to record my 3rd person character and while it records the movement correctly for some reason the whole character is rotated. On the left is my character in-game and on the right is his recorded sequencer version.

You’re experiencing the exact same bug/behaviour as we are. I have not found a solution, but maybe a workaround that can be used in some cases: When recording a sequence, it records the sequence itself and also an animation sequence in the /Animations folder. This animation seems to be correct, and can be dragged out onto a new sequence to be played back.
To me, it appears as both the capsule and the character gets animated, and when played back the character is offset from the capsule. It does not explain why the capsule is recorded with the wrong axis or that the keyframes are offset, so I believe this has to be answered by the @Unreal animation team.

Did you manually change your pivot point in editor from its original origin on import?
Try this:
In sequencer, on the “Transform” tab under your asset, select the + button ("+ section" when your mouse rolls over it)
Add an Additive Track.
You’ll see another transform track appear below the first.
Right click on the new transform track and find and select “Key This Section”
Now you should get relative offsets on playback

1 Like

This still happens in UE5.01 also
Tried all options.
Best to create another actor at your pivot you want to animate the parent your object under that. Animate parent object to get no transforms on rotation in sequencer.
Please fix


Thank you so much @cheeseyscones this is actually the only solution that worked for me!

1 Like

Same issue - seems strange that there’s still such a massive discrepancy between viewport and sequencer output, will try your workaround, but crazy huge frustrating bug from the POV of anyone trying to create cinematics in UE5.01

This solved it for me, thank you!!

@jonathanirwin2 What “specifically” solved it for you? Which of the suggestions…? I’m still having issues.

I found the root of the problem when I exported the fbx model from cinema4d. The anchor point around which the sequencer rotates, and which you cannot untie, is cinema4d’s world coordinate point. I moved the object in cinema4d to the center of coordinates, re-export and now the sequencer in UE rotates the object as I need. But, of course, this is not a solution to the problem. The object in the sequencer must rotate around an anchor point that you can assign yourself, just as it does with normal transformations.

1 Like

I had a similar problem with a skeletal mesh downloaded from epic store market (so idk where the assets comes from). I solved it by creating a BP in which I put the Skeletal Mesh and place it so that the desired pivot and the (0,0,0) of the BP match.
It is then the BP I use in my world and sequencer :slight_smile:


that worked for me, thanks

Perfect! Thanks!

Im sorry to Necro the thread, but for anyone having troublenqith this like i did in the future, the workarounds mention will work fine. But what solved it for me was to zero out the world position in my 3d software when i export. It seems even if you change the pivot in UE5 or in my case 3ds max, it still will only scale and rotate to that 0 position in the fbx file