obj import not working: scale is smaller than original


I have tried to find answer in previous posts but after trying the solutions previously mentioned and still failing, I decided I would give it a go and ask for support here.

As the title implies, I am trying to follow the workflow of Aligning — Generating high res mesh — Export it for retopo and uv in Modo / Zbrush — Import — Project Texture on imported mesh —Re export. 

However, I am failing towards the end of this process, namely at importing the retopoed mesh. No matter what I have tried, it always comes in much smaller than the original. 

I have tried to copy and rename the rcinfo file so it goes with the exported mesh at the import time. I have also tried to over write the original mesh that I exported from RC with the retopoed one. No matter what I have tried, they always come in much smaller than the original… 

If there are more settings I should check, please let me know and I will check them. 
Also, if you need any additional info/data, please let me know and I will provide it as soon as possible. 


Thank you for your time!


Hi Emil,

how exactly do aou determine that the model is smaller? Do you have actual measurements or coordinates or are you simply judging by the appearance? I’m asking because the displayed grid in RC is pretty much random and does not reflect the actual size, at least in my ecperience. So it might be worth checking that out.

Hey Götz!

Well, to me it seemed very obvious because I had the cameras icons visible so when I would import the originally exported mesh, from RC, it would have the proper size, even in relation with the cameras but then when I would try to import the one from Zbrush/Modo it would be very very tiny in the origin of the world, and I could see that clearly in relation to the above mentioned camera icons. 

I can try when I get home tonight to do a projection but I m pretty sure it will not work… 

Also, it s worth mentioning that I tried to import in Modo, both the original mesh exported from RC and the retopoed one, and in Modo, they matched perfectlly. 

Hi Emil,

hmm, in this case it might be different. Then it seems to me as if something happens before re-importing. Is it possible that there is some confusion between point and comma in the coordinates? Do you use Grid Plane or Project Output when exporting the mesh?

I believe it’s Project Output but I am not sure… where is the option/setting so I can check it?

Side note: I am very new to Reality Capture (have been using Agisoft for AAA games before but only now I m trying to RnD Reality Capture because it seems to give better results so far… or have the potential to :slight_smile:


Also, thank you very much for helping me with this :) 

No problem!  :slight_smile:

You can set it in the menu that pops up when you export a mesh. Grid Plane is a reative orientation and Project Output is according to a geo referencing, if you have one.



Sorry for the radio silence but I wanted to try a bunch of stuff before coming back to reply.

So, to answer your last question, it appears I am using Grid Plane. Is that ok? I believe that’s the default. 

Now… I managed to import a retopoed mesh and even texture it and all… But there is something very strange happening. First of all, it always worked only if I saved the retopo mesh over the one exported from RealityCapture. Even if I would copy the original one, rename it together with the .rcinfo file and try to overwrite that one instead, with the retopoed mesh, it just wouldn’t work. 

My workaround this was to always copy a backup file with the mesh exported from RC that I would just keep on the side. And in this way, I could still export the retopo over the original export but still have that original mesh as well, as a backup. 

While the issue mentioned above is strange, it doesn’t bother me to much since I found a workaround. The next one is the one that I have a hard time understanding what’s going on… 

It happened to have a scene processed for a few days or so, and then, when I re-open it and try to go through the process of exporting orginal mesh  – retopo  – import – texture, I would get again the problem with the little mesh in the origin. 

It happened to me last night… so I tried exactly the same steps described several times above, in this post and the other posts and at the end it arrived super tiny, and in the origin. I closed the scene, created a new one, imported the photos again, align, process the dense cloud, generate a new mesh, export that one, retopo, save the retopo on top of the one the file that I exported from RC, import in RC, and … it worked! With no problem… I even closed the scene and re opened it because I wanted to see if I modify the retopo one and save it again, will I be able to import it properly? It worked as well… so why did the scene that I opened the first time didn’t work? 

Here comes a bunch of prolly very very stupid questions but I have to ask: 

  1. is the fact that a mesh is colorized/textured affecting somehow the .rcinfo when exported?
  2. are there any options that might affect the imported meshes only in certain circumstances? 
  3. is there anything I can do before I close a scene to make sure that if I open it again in a week or a month, I will be able to just continue working and import retopoed meshes?

I know that at this point I can basically work in RC and do what I need to do but this whole thing where it feels a little bit like lottery whenever I import a retopoed mesh, just feels wrong to me and I would love to be able to nail it down and know what s happening. 

If you guys need me to create a few example scenes and send them your way, let me know and I can do that… some files might be quite big but I guess I can use Google Drive or something. 

Thank you and sorry for the long posts but I’m thinking this might help people in the future as well if they will bump into this problem.


Hi Emil,

great that you found a workaround! No idea why it would only work in the way you described though…

I also can’t help you with your further questions.

The only thing I can say is that if you are absolutely certain that you did the same thing and you get different results, then there must be some bug involved. Responses are usually better in the special section of the forum…  :wink:

This is an old thread, but I’m going to write this down before I forget… 

I’ve been having a nagging scaling issue when retopoing scans in Zbrush: models imported to RC are correctly aligned, but are often way too small. What’s worse, the whole issue seems to be quite random, and messing around with the rcinfo-file does not help.

Today I realized it’s related to Zbrush changing the scale of the scene during some part of the retopoing process, even if you don’t touch the scale or click anything related to unifying scale.

Here’s a workaround in Zbrush:

  1. Select your retopoed model. Click Zplugin > Scale Master > Sliders to Subtool Size. If the X-Y-Z-sliders show values of 2, your scene’s scale has most likely been messed up at some point. Export your retopoed model.
  2. Make a new scene and import your hipoly model only. Check the scale again with Scale Master > Sliders to Subtool Size. This should be the correct size of your object. Wwrite down the X, Y and Z values. Turn your hipoly mesh into a polymesh (Tool > Make PolyMesh 3D)
  3. Import your retopoed model to the scene. Select it, use Scale Master, enter the correct values for X,Y and Z and click Resize Subtool. Uncheck “All” option, you don’t want to scale the hipoly model.
  4. Your retopoed model’s size should now match the hipoly model. Move the retopoed model to the same position as your hipoly model. I’ve used Positioner script for this.
  5. Hit export. The model should now import correctly to Reality Capture.

It’s worth noting, that the scale of the hipoly and lowpoly models might not be 100% identical after the retopoing process. I’ve had good results entering the same values for both objects though.

Hopefully someone finds this useful, took me way too long to figure out. Still waiting for the “Match objects”-button.

Why isn’t there just a scale adjustment slider in RC? What if I’m trying to combine a photogrammetry scan with a laser scan? Seems like a no brainer to have something that basic if so many workflows use round-tripping through another program.

Hi NormalKyle,
there is not a slider, but you can set the scale during export or import: image
Also, if you will combine the data, in mostly cases it will be scaled according to the laser scans (as photogrammetry is basically scaleless). It also depends on used settings, but there is no problem with that option. You just need check if you have set the coordinate systems and export settings correctly.