Download

NVIDIA VXGI Integration

Does anyone have some ideas on what could be going on here? All I am doing is rotating the room (NOT camera) so that the faces are no longer aligned with the voxel grid. I get strange uneven/banded lighting on everything and it’s most noticeable when moving light sources which cause voxel-shaped jumps in lighting, BUT I looked at an old screencap video and it wasn’t there. I know I’ve changed a config somewhere that must be causing this, but I can’t for the life of me figure out what!

Halp! :confused:

This is aliasing in voxel space. A known problem, and currently there is no good solution for it in VXGI. Try the following things:

  • Change the room material’s Opacity Voxelization Noise Scale to something non-zero;
  • Adjust diffuse tracing parameters to increase the initial tracing offset;
  • If the room has an outside wall that’s lit, try removing the light from it or move it further away from the inside wall;
  • Finally, try setting r.VXGI.HighQualityEmittanceDownsamplingEnable = 1.

Does this also happen in VXAO mode? (r.VXGI.AmbientOcclusionMode = 1)

Ahh I have found the problem. Someone had set diffuse tracing initial offset distance factor to 0.0

Thanks Alexey

I’m having some issues getting VXGI Ambient and VXGI Specular to work at the same time. It seems when I activate VXGI Ambient, the VXGI Specular is disabled or not contributing. Has anyone seen this or have a solution?

Specular won’t work in VXAO mode (r.VXGI.AmbientOcclusionMode = 1), there is no color information to compute it from. Or do you mean full VXGI mode with ambient also enabled by setting the ambient color to non-zero?

I think your post gave me enough insight to figure out the issue. I was expecting the VXGI Ambient to work like most instances, where you would use black and it would contribute in the occluded areas. After adjusting the Diffuse Color to something lighter in tone, I realized that its actually contributing like ambient light, not ambient occlusion. Makes sense now. Thanks for that, sometimes its the little things.

VXGI integration in UE 4.13:
https://github.com/NvPhysX/UnrealEngine/tree/VXGI-4.13

As usual, there still may be some issues, so please use with caution.

Big thanks to @GalaxyMan2015 for the initial porting to 4.13!

VXGI is working only with Directional Light enabled? I’m thinking about indoor first person dungeon with point lights. It will work without directional light?

VXGI works with all light types. Including the skylight (make sure the VXGI flag is set. Dont remember the name just search for it) and for emissivr materials.

I was going to post with a question about a problem with what appeared to be a constant ambient light that was affecting my scene, however, I managed to figure it out and thought it would be useful to add to the top post of this thread, simply because it’s a setting within Post Process Volume that is not set properly for VXGI by default.

My scene was being lit by some mystery source of flat lighting (although BSP was unaffected). After much hunting, I found that changing the “Indirect Lighting Intensity” to 0 under the Global Illumination tab of my Post Process Volume fixed the problem. It might not have been that noticeable in a scene lit by a skylight, but with a single tucked-away spotlight as my light source, it was a pretty annoying problem. Before and after shots are below:

Post Process Volume >> Global Illumination >> Indirect Lighting Intensity: 1.0 (ugly)

Post Process Volume >> Global Illumination >> Indirect Lighting Intensity: 0.0 (beautiful)

EDIT: I also realized that this could’ve been solved pretty easily by just disabling static lighting of any kind in the project settings menu. Doh.

Landscape Material Error

I am using 4.13 VXGI, when i assign a material to a landscape, the following error happens:

428dd7c09ffb0fe4493ede9d58afea998f175f75.jpeg

This only happens with this particular material. Here is the material setup:

bd6e7ae58b37631ea990467500eb43aeedf17ca8.jpeg

**This same material however works fine in 4.12 without VXGI.

I found that this error is reproducable. It happens everytime when blending materials in landscape, like combining rocks and grass and leaves…only happens in VXGI dynamic without lightmaps, the error says some shader with no lightmap policy is missing…

I’ve also posted this on the github issues page.

No doubt an issue when I ported the code to 4.13. If alexey doesnt get to it first. Ill take a look after Monday

I can not properly import a FBX file. The textures are not showing up in the editor. With the normal version of Unreal 4.13 I can Import the same fbx and the textures without any problems.

For me it looks like a bug in the VXGI-4.13 version. I tested it also in the UnrealEngine-VXGI-4.12 with the same Fbx and other Fbx files and everything is looking nice. Do you have some ideas?

Nothing about the FBX import process is touched by VXGI so really shouldnt have an impact.

So when u import ur FBX u have the checkbox “Import Materials/Textures” ticked? And its not importing textures at all?

Exactly. It seams that the uv coordinates are not imported. The UV Chanels 0 and 1 are empty. Any further ideas?
Thx for the quick reply.

So it is importing textures, but messing UVs up? This is an important difference as its two very different parts of the process at play

The uv coordinates are not imported. The UV Chanels 0 and 1 are empty.

The uv coordinates are not imported. The UV Chanels 0 and 1 are empty in Unreal.