nVidia Physx Cloth

Hey everyone! I hope to find a bit of help with nVidia’s PhysX clothing. For a bit of background, I’m using Max 2017 with the DCC plug-in for PhysX 3-3-4 version 3.4, as the latest version 4.0 doesn’t seem to support Unreal Engine 4.13 [well, rather, 4.13 doesn’t support Physx 3.4…]

Moving on, I’ve been cross-referencing a few different tutorials via youtube to make sure my workflow is right, and best as I can tell, it is, even though they’re all using Apex which seems to have been phased out and renamed as part of the physx rollout (or something…?), however, even with an object as basic as a flag, I’m getting some mighty awful skewing [see attachment, showing what is supposed to be a flag] and I can’t for the LIFE of me figure out what is causing it. I use Unreal Engine 4.13 recompiled with VXGI, so I thought maybe something was wrong with the build, and tried the same process with vanilla 4.13 and have the same results [or lack thereof, I suppose].

I’ve tried manually setting the scale to cm and re-exporting, to no avail… I’ve tried completely rebuilding the assets from scratch [this works about 10% of attempts for reasons I can’t identify!] and I’ve been combing the internet and the forums for a clue or an answer and have come up with nothing… so I it’s gotten pretty frustrating.

Anyway, any help would be greatly appreciated as I’m at a loss and eager to get the project moving along. Should no solution be presented, I wonder if there is an alternate physics solution that’s relatively easy to implement that might be worth considering?

Thanks in advance!

Same Problem:


I’m not sure to bring you the solution, but I’have been able to use apex clothing in UE4.14!

There is 2 plugins in nvidia download center:

  • PhysX: 3D Studio Max DCC plug-in for PhysX 3-3-4
  • PhysX: 3D Studio Max DCC plug-in for PhysX 3-4-0


  1. Physx v3.4.0 make 3dsmax 2017 crashing when adding clothes to a meshes with skin and bonnes attached
  2. Physx v3.3.4 works well in 3dsmax 2017, but there is export/import problem in UE4.14 and you can see the mess you have!

My solution is :

  1. Install Physx 3.3.4 for 3dsmax 2017, make my meshes, add bones, skin and clothing.
  2. Close 3dsmax 2017
  3. Uninstall Physx 3.3.4
  4. Install Physx 3.4.0
  5. Open Scene in 3dsmax (simulate if necessary)
  6. Export Meshes/bones/animation using Menu=> Export => Game Exporter (use fbx2013 format ui advanced export paratmeters)
  7. Export you apx
  8. Import all in UE4.14