Download

NVIDIA GameWorks Integration

hey guys can someone confirm this??? Visual studio will not build ue4 hairworks - UE4 AnswerHub

The HairWorks branch is only at 4.12.4 which means it doesn’t contain the necessary fixes that are in 4.12.5 that allow VS2015 SP3 to work. Try my branch, its built to 4.12.5 and therefore works fine with VS2015 SP3, I know as thats what I am using.

Thank you GalaxyMan2015 for all your hard works.I am very happy that you after a long time released your branch.Well i have two questions:

1)Is this branch is like your last release 4.9.2 with vxgi,flex,hairwork and wavework?
2)Do you have any plane for releasing your branch again in 4.13 version.because of big features in 4.13 like vertex animation,alembic importer and so many features.if no can you explain briefly how i can merge all nvidia gamework branches into one like yours.
thanks for your reply.

yes and Cataclysm

There is really no step by step guide, sometimes its easy, especially when the branch NVIDIA has is the same version of UE4 as the one your merging into, such as it was this time around for most of them, other times its much more challenging, like upgrading WaveWorks from 4.9.2 to 4.12.5. As a lot of rendering changes were made, so had to modify a lot of code to make it work again.

Wow Cataclysm.thanks for reply

Hello, thank you for this compilation GameWorks. Everything works and vxgi is impressive.
That said, the anti-aliasing (FXAA and temporal AA) does not work with me. Do you know how to fix this?

Yet it is enabled in Project Settings and postprocessing. It is a rather annoying problem, thank you in advance. I use UE4 12.5

FXAA only works if I force in the nvidia driver. But AA temporal really does not want to work. I have tried disabling SLI, but it changes nothing.

Please, AA temporal is more important than VXGI, but I would really use VXGI too. I have no idea how to fix this …

For some reason, I had to set r.PostProcessAAQuality 4 in the console to get AA working.

Super, it worked, thank you! I was afraid not to use VXGI because of this problem. And I found no solution on google …

Thanks again.

Everything works fine with HairWorks, including simulation from animations and wind effects, but when my character moves around the hair doesn’t react at all.

What am I missing here?

You need to use root motion of some kind to have hair react to movement, as it will not respond to just the character moving around. ie. I animated the root bone of my animation to bob up and down to have the hair react to moving around.

Thanks for finding a solution, I’ll look into why its the case.

Unfortunately, this fix is only temporary. AA temporal off unexpectedly randomly … then have to re-enter the console command.
As long as you are in the GameWorks compilation, you will be it possible to add PhysX Dynamic Heightfield in addition to all that you have included?

It would be really great to have a ground which is deformed. I tried to integrate Polyvox to EU4, but I am not happened … I’m a beginner …

Probably not, as this would only take care of the collision data, would still need to rewrite the rendering portion to support actually changing the landscape tris. Not a trivial task, and I am not really in need of this functionality at this time.

I understand. Anyway I thank you again for compiling features nvidia, it’s really nice.

I figured it out, its part of the NVIDIA upscale algorithm thats in Cataclysm. It disables AA. Open up the ConsoleVariables.ini and remove the below entries. If you want to use the upscale algorithm in the future. you need to set those params again.



; NVCHANGE_BEGIN: Improve super-sampling
r.Upscale.Quality=4
r.ScreenPercentage.Editor=1
r.ScreenPercentage=100
r.PostProcessAAQuality=0
; NVCHANGE_END: Improve super-sampling


Thank you very much, I raised several times the editor and temporal AA works normally.

With the official integration of Hairworks 1.2 into Unreal 4.12, has anyone experienced performance lag when simulating hair?

To test what I was seeing in the engine, I’ve loaded the same exact project in FurViewer versions 1.1 and 1.2 and noted that Hair will now act very stiffly even jaggedly, and in “slow motion” when animated in 1.2 as opposed to 1.1. where the hair animates normally. Additionally, when the model stops animation, the hair flows freely.

Initially I attempted to re-adjust stiffness and gravity, however when I noted the jagged nature of the Hairworks animation I understood that it may be related to an Animation+performance issue that turned up with the update .

Has anyone else encountered this? Specifically with shoulder length hair.

Not sure if this will help you or not, as I did notice much stiffer simulation with the same settings in v1.2. Until I set this console command in UE4:



r.HairWorks.FrameRateIndependentRendering 1


Hi Galaxyman :slight_smile:

Thank you for the advice!

I tried that (and every other Hairworks console setting I could find that could potentially solve the issue) which didn’t show much difference, however I’ve just figured out the solution.

I re-exported the original Hair asset from Maya using the new “1.2” HairWorks plug-in and lo and behold, the hair works perfectly!

Apparently some 1.11 assets wont work as intended with the latest build. (I have another 1.11 asset that seems to work fine)