Download

Numpad Point Key

I requested this via the Editor feedback buttons some two years ago, but there’s been no change. Maybe it’s too big of a feature? :wink:

I’m Finnish. In Windows, by default, my input settings are set as Finnish. In our language we use comma (,) as the floating point delimiter. So, 40.55 in our language would be 40,55. We don’t use commas to group thousands and millions etc. at all.

The problem? The numpad point key with Finnish language settings spits out commas. And if I type 40,55 to some input field in the Editor, it will just discard the ,55. It’s a real pain in the ass having to reach out to the dot key next to space bar every time you need it. Especially since there’s a perfectly good point key in the numpad that I use all the time with all the other applications. And many of them change the input value from 40,55 to 40.55 dynamically, no problem.

In UE4 you use floating point values A LOT. So, I would appreciate it, if something could finally be done to this.

Yep!

Meanwhile I’m just rebinding this key :wink:

The old method: app for changing registry entries

My current method, using MS tool to create my own keyboard layout. Polish with edited comma/dot :slight_smile:
https://www.microsoft.com/en-us/download/details.aspx?id=22339

4.19 has locale correct numeric input and display for the details panel and BP nodes, so providing your editor locale is set to Finnish you’ll be able to use the comma as the decimal separator.

Great news, Jamie Dale! Looking forward to the new version. :slight_smile:

Indeed. Funnily enough, I only noticed it this week, found the old thread from 2015 and was a bit disappointed that nothing has happened since :smiley:
Great news!

So, Jamie Dale I’m using 4.19 now and the comma still doesn’t work. Input like 1,2 changes back to 1.0.

What is your editor locale set to? (under Editor Preferences -> Region & Language)