Numerous errors in trying to compile Unreal Engine 4

Hello, I have tried numerous times to try to get Unreal Engine 4 to compile on Ubuntu but it doesn’t seem to be happening. The first error I run into is: E: Package ‘libmono-corlib4.0-cil’ has no installation candidate

You can see the terminal output below:

./Setup.sh 
Registering git hooks... (this will override existing ones!)
Attempting installation of missing package: libmono-corlib4.0-cil
+ sudo apt-get install -y libmono-corlib4.0-cil
[sudo] password for jr: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libmono-corlib4.0-cil is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  mono-reference-assemblies-4.0 mono-devel

E: Package 'libmono-corlib4.0-cil' has no installation candidate

I have errors that follow a possible solution I have found, but I would rather get my solutions from this community. Than some random source on the internet. Thanks for helping me with this guys!

Oh and I am only posting one error at a time. The other errors may be the result of “solutions” causing new problems. So I guess I will just take these errors one at a time.

hey Joeschmo-

The message starting at line 9 mentions that one of the packages is no longer available and has been replaced. If you install the package mono-reference-assemblies-4.0 mono-devel you should be able to run ./Setup.sh after.

Cheers

Doug Wilson

Just try to install mono manually with

sudo apt-get install mono-complete

or

sudo apt-get install mono-devel

If your under debian I think you have to use apitude or add mono to you dependencies